0.20 is a disaster for GS290 if on Three UK

Sorry to post here and for the drama but 0.20 has made the GS290 not workable as a phone. The basic functionality of the Internet and Email is constantly breaking between LAN and WAN and Access Point names seem to randomly switch.
I have posted this on the Wiki and on the dedicated GS290 forum but I’m posting this here because it’s been a few weeks now and it’s urgent!

As this is a purchase-able phone from /e/ surely there must be a fix by now?



Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Could this be a specific issue with or your hardware, or WiFi configuration?

I didn’t experience any trouble on Gigaset GS290 running on 0.20-q

I’m not the only one- check the GS290 thread…but yes it could be hardware or service provider related I guess. I’m with Three in the UK.
0.18 was perfect, no problems. This started at 0.19 so I quickly upgraded to 0.20 and it all went bad :slight_smile:

OK I should qualify the thread title- “if on Three UK” …apologies

I have a Gigaset GS290 AND just updated to 0.21. I am on 3 network in UK and have lost access to mobile data. I notice this thread doesn’t seem to have any advice or fixes. Are there any known issues with updates on the Gigaset or 3 network?

I have tried restarting and complete power-off, but no success. Of course the phone cannot work as a hotspot now.

Can I alter settings? I have tried turning mobile data off, then on again. Anything else worth trying. Can I revert to a previous software version? If so, how?

Hi Steve
Yes you have to redo the APN settings as in my other post?

This topic was automatically closed after 10 days. New replies are no longer allowed.