"Add website to home page", but nothing shows up ^^'

Hi !

I’m still on my way to fully embrace /e/ (thanks again for all the great advices), and for that I’m trying to get rid of some non-useful apps. I’d like to replace them with links to the website.
For that I open my browser, “…”, “Add website to home page”, “ok”, then a confirmation message appears and… nothing. No new icon, no nothing. ^^’

I tried it with Brave (my main browser), Brave bêta, Firefox Focus and the /e/ browser.
I’m on OpenLauncher but tried with Lawnchair too (just to check if it was the cause) : same problem.
I’m on a FP3+ and /e/OS 0.13-2020121490323

I’ve searched on the forum and just saw this topic but the problem isn’t the same (the option appears in my case).
I anybody already had this problem, I’d really like to hear about your ideas !

Thanks again

This is a known issue: Adding a shortcut to the Home Screen only works with Bliss /e/'s default launcher / Hme screen app. I raised this issue #1529 in gitlab several months ago. It seems to have been ignored because it has wrongly been labelled as a Nougat issue. In fact it occurs in Pie and Q builds also

Works for me without a problem using Fennec F-Droid and the old Lawnchair from F-Droid.
Fairphone 3 on e-0.13-q-2020120789006-dev-FP3, but this has also worked with prior versions for me.

It works for me too using Firefox.
It doesn’t work with the default Browser app - the shortcut is added to the Bliss Home screen even though Bliss is not the default Home app.

I have added a comment to the defect so it doesn’t get ignored :slight_smile:

Oh, thanks ! I guess I’ll wait.

But I’m not sure it’s the same than you two : Like I said, it doesn’t work for me with Brave/Lawnchair, Firefox/OpenLauncher, Firefox/Lawnchair… and with Fennec I don’t have the “add a shortcut on home page” at all.

When I use Bliss, where should the shortcuts be ? The first page is just the search bar, the weather and a vertical list of widgets, and the other pages are all the apps (yeah, I’m quite new here, sorry ^^’).

Thanks for the addendum in the gitlab issue !

That is interesting. Brave is based on Chromium, as is Bromite (the /e/ browser) and neither of them work. Fennec is based on Firefox, nothing to do with Chromium, and both of those do work, so maybe it’s a Chromium issue.

When it comes to where they should be, I guess you could check the requirements specification :wink: Seriously, Bliss is a new app, in my opinion it’s pretty much still only beta-quality (if that), and its behaviour is not well-documented and is sometimes prone to change without warning from release to release. From a quick play, I think the shortcuts get added on the rightmost page - keep swiping left until you see them :slight_smile:

I would stick with Lawnchair or OpenLauncher, unless you really want a copy of the iPhone experience. For me Bliss doesn’t add any value me and fails to offer the sort of functionality that I want from a Home / Launcher app. Others will of course have different opinions :slight_smile:

In case of a PWA-capable website, you might have “Install” instead, see here …

Aaaaand it’s not. Whatever, I prefer OpenLauncher. ^^

Here’s what I have on Fennec… I’m gonna think my device is just cursed ^^’

image

1 Like

Which page did you open?

Here’s what I get with this topic’s page … apparently this forum website is PWA-enabled, so it’s “Install” …

Screenshot_20210113-152057_Fennec

… and here’s a random non-PWA-enabled page with “Add to Home screen” …

Screenshot_20210113-152514_Fennec

… with Fennec F-Droid 84.1.2.

Screenshot_20210113-152119_Fennec

(Just after that I saw the update notification, so I can also confirm it works for me with Fennec F-Droid 84.1.4.)

No “install”, no nothing.
I think /e/ is just messing with me to see if I’m gonna be strong enough to hang on.

Screenshot_20210113-154840_Fennec

Screenshot_20210113-154933_Fennec

At least in OpenLauncher it seems to be not a bug, but a (non-)feature …

“dkanada commented on 30 Jun 2020
It was never implemented in the launcher which is why nothing happens.”