Aïe everything is KO

I’ve got A Fairohone 4 wich was running good with /E/ OS.
I wanted to tried LineageOS bue everything went wrong.
I only got the boot loader screen which says “Device state : Looked”
and when I go the “Recovery mode” I’ve got menu from LOS : apply update/factory reset / reboot system / etc.
I tried evry menu and nothing is working on well.
I obviously used the latest file proposed on LOS sie.

SO I’d like to come back yo /e/OS or Fairphone OS but impossible !!!

Any idea ?
Best wishes, and thanks,

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

You need to unlock the Bootloader first. Please see whole installation instructions for LineageOS here:

1 Like

But it’s quite strange since I already did it to install /e/OS insteat of FPOS
And know since I can boot any OS on my phone, I don’t have acces to my IMEI number neither serial number !

I supposed that you relock your bootloader since this is possible with the Fairphone 4.
Device state : Locked” usually hints that bootloader is locked…

1 Like

OK, since IMEI is written in the battery case of the phone and serial number written on lineageos bootloader on phone, I get now my unlock code … but … I just can’t do anything since I can’t access to any OS (I run only linux on my computers) !

Whatever OS you want to install … your bootloader is locked now, and you are able to get into fastboot mode. So first try to do the steps necessary in fastboot mode to unlock the bootloader. Any error messages with this?

Or you could try the Easy Installer and see whether you can skip the first steps until it tries to unlock the bootloader in fastboot mode (at least I suppose the Easy Installer doesn’t let the user do this manually).

1 Like

I run DEBIAN on my computer and already tried to install EASY INSTALLER, nothing to do I can’t mange … I guess I’ve got a pb with SNAP.
Anyway, after recovery mode screen, I have 2 possibilities

  • Recovery screen
  • Fastboot screnn
    And any of the command given here and there, it doesn’t work

Yes I do have error message but so many with each command … so I can’t put here all of them … it will take one day to write.
I’m going to write you 2 or 3 !

For instance exemple of basic commands

adb reboot bootloader

It’s OK

fastboot devices

It’s OK

fastboot flash recovery recovery.img

fastboot: error: cannot load ‘recovery.img’: No such file or directory

And what’s the result of fastboot flashing unlock?

adb devices

it’s OK

adb reboot bootloader
  • daemon not running; starting now at tcp:5037
  • daemon started successfully
    error: device unauthorized.
    This adb server’s $ADB_VENDOR_KEYS is not set
    Try ‘adb kill-server’ if that seems wrong.
    Otherwise check for a confirmation dialog on your device.

(So I did it again trying “adb kill-server” I’ve got same result)

And nerver message on screen of phone

fastboot: usage: unknown ‘flashing’ command unlock?

And maybe also the result of
fastboot flashing get_unlock_ability?

fastboot: usage: unknown ‘flashing’ command get_unlock_ability?

The “?” is not part of the command to execute.


It’s subtle, but visible.

1 Like

Obviously ;o) …

fastboot flashing unlock

FAILED (remote: ‘Unrecognized command flashing unlock’)
fastboot: error: Command failed

fastboot flashing get_unlock_ability

FAILED (remote: ‘Unrecognized command flashing get_unlock_ability’)
fastboot: error: Command failed

And the following?
fastboot --version

1 Like

fastboot version 28.0.2-debian
Installed as /usr/lib/android-sdk/platform-tools/fastboot

Can you please try to update it?
In my case is e.g.
~$ fastboot --version
fastboot version 34.0.4-10411341
Installed as /usr/lib/android-sdk/platform-tools/fastboot

1 Like