Backup restore not available in "settings" on Teracube 2e

i hope i found the right category.
My problem, as my Fairphone 4 has problems with GPS and has to be sent to repair center for repair, i wanted to switch to a Teracube 2e (2020) for the meantime.
I’ve made a backup on the Fairphone (settings/system/backup) with Seedvault, but when switching to the Teracube, there is no “Backup” in /settings/system.
Am i doing something wrong?
Both phones have installed the newest versions - FP4: 1.8.1-s-20230203 and Teracube: 1.7-20230110
A hint how i can restore my backup to the Teracube would be great.

Hello @hugofant

Here is sort of the same, a couple days ago.

Edit: I forgot to pa.te the link:

Version 1.8.1 dev and stable are availble for the 2020 Teracube “2e”. You should be getting an update notice soon.

Was wondering about something as I haven’t been followimg SeedVault topics. Is it availble on Q/A10? My mata running 1.8.1-q (dev) does not have Settings → Backup either.
My Teracube emerald with 1.7-r (A11) does have it.

So is it really missing or just not available?

@mihi: thanks, i’ve tried the solution mentioned in the thread, but phone is doing nothing after pressing *#*#7378673#*#* :face_exhaling:
@tcecyk : actually i’ve no experience with ADB…have to “work in” for being able to understand your info - and this will take a few days

@marcdw : version 1.8.1 is now installed, but no difference in behaviour…and there is still no “backup” in the Settings :thinking:
What do you mean with

I thought, that the difference between zirconia and emerald would be just minimal (same hardware), and you said there is a “backup” in your “Settings”

What I meant was, is SeedVault available on Q/A10 in general.
The 2020 Teracube runs Q and has no Backup you say. Same for my Essential PH-1 with Q, no Backup.

The 2021 Teracube runs R/A11 and does have Backup/Seedvault. So does crDroid A11 and LOS 19/A12 (unofficial).

For the sake of argument let’s say SeedVault is not available on Q. Without it there would be no Backup in Settings at all in a deGoogled ROM as the standard Backup uses Google.

Since I do not know much about SeedVault I am asking/wondering more than anything else.

@marcdw Seedvault is always packaged with all /e/ versions since 2+ years, but it doesn’t get any focus since inclusion but to hide it more sadly. Its version is falling significantly behind, but this also relates to the latest Seedvault being only compatible with the latest Android Calyx uses, so different builds are required for Q/R/S and are thus harder to support for /e/ if they would support this.

@hugofant - adb root will always work, enable devmode by the 7-tap, enable root-debug, install adb on a host computer

1 Like

@tcecyk : took some time to get adb to work (virtual desktop blocked the port), but now it works.
But when testing my first backup its says it’s deprecated and after doing some research it seems, that there are already some limitations on Android 12 (and 1.8.1 is android 12).
…or have i undestood something wrong??

as to the stackexchange link: “adb backup” is separate from Seedvault, no connection on those topics?

For limitations of Seedvault itself (if it works) see Seedvault not backing up all App userdata (#3691) · Issues · e / Backlog · GitLab - basically you need A13 to make real use of it and the latest Seedvault version. What /e/ ships is >1-2 years old as of now

sorry, i don’t understand, what you mean to say - i was reflecting on your words

so I’ve tried to go this way…but then it seemed, that this is also not possible (depricated). So i was asking, if i understood something wrong.

(have no idea what Q/R/S means…

so, in short: Seedvault cannot be used for my requirements (backup restore, on my both e/os phones), correct?
…and adb is also not working on A12.

So is there any way to make a "full local backup " with e/os for making a phone switch more comfortable?

adb backup is deprecated, but Seedvault itself is not. Two different things. It’s possible I suppose Seedvault itself complains about its own archive version on restore if there is version drift, can you post the screenshot of when something fails?

Those are release letters of Android itself. Q is Quince Tart and means Android 10 and so on… R=11, S=12, T=13

it’s not yet a complete backup solution, but it brings “some” advantages, at least being able to restore all apks, so no reinstall necessary, call logs… my position on this always was it’s better than nothing and should’ve not been hidden.

A complete backup as of now involves root access - [HOWTO] Backup and Restore Data on Android Devices - #52 by petefoth