Bad idea? Installing /e/ gts210vewifi on gts210velte


unfortunately my gts210velte (Samsung galaxy tab s2 with LTE) is not supported by /e/ right now - however, /e/ is available for gts210vewifi (galaxy tab s2 without LTE).
If I install /e/ gts210vewifi on gts210velte, will I brick my device? Will it work at all? Since I don’t need LTE I wouldn’t miss it.


[LIST] /e/OS Supported Tablets

according to gsmarena, SM-T813 and SM-T819 seems to have the same chipset.
make more search → xda
But in your case, you can have a try flashing this file, only “data connection” and calls are expected not to work.
if you are authorized to flash by the .ZIP “meta-info” (it may need some combinations) it will be cool…

Be ready to flash back to stock Samsung OS if the installation don’t works

1 Like

I’m confused about the codenames now…:dizzy_face:
In this list there’s an unofficial /e/OS build for “Galaxy Tab S2 9.7 (2016)” called “gts210ltexx (LTE)”

But on TWRP:
Samsung Galaxy Tab S2 9.7 LTE (2016) (gts210velte)
Samsung Galaxy Tab S2 9.7 2015 (LTE) (gts210ltexx)

The “xx” is a confusing thing - it is historical and you just have to take a leap of faith that all issues were resolved before the new nomenclature.

Otherwise device names are “very” specific (unless there are other examples :slight_smile: )

1 Like

Is it a T819 ?

Yes it’s an SM-T819N to be precise. So the twrp codename should be gts210velte. It is from 2016 and has a Snapdragon SoC. The gts210ltexx is from 2015 and has a Samsung Exynos SoC instead. I’ll try to install /e/ gts210vewifi in a couple of days. If it doesn’t work, my guess is that with a proper TWRP as recovery I will always be able to rollback to a different ROM.

Hi, just installed /e…wifi (sm-t813) on sm-t819. Working good so far. Of course without cellphone functionality, which I don’t mind. Better than unofficial lineage, which also has camera problems, besides cellphone. Also /e is updated regularly. One problem there. Twrp flash gives error 7. Still sees tablet as t819, while everywhere in /e it sees t813. Almost sure I did update once (first time) succesfully. Not sure about what’s wrong. Pity, because my real sm-t813 is updated perfectly on a regular basis. But maybe this is for other topic. I’m new here. Trying to find my way.


OTA updates could not working

You may have to modify the meta-data into the file adding référence to your device codename gts210velte, to make it matching with TWRP as explicited in this post

1 Like

xx at the end of a build codename, means it is an unified software including devices variants that are listed into the .ZIP file meta-data

Thanks piero. In your links at least I found the location of the downloaded update. Didn’t know that yet. Told you, I’m new on this. See if I can upate manually now. Have to remove the updater-script device-id again, of course. Did that first time too, otherwise error 7. Wondering about a way to change the device-id in the t819 to t813, permanently and all over the device, as this is obviously not the case now. I still have the idea that the first update after the complete reflash to a t813 was succesfull, but maybe I’m confused and wrong about that, because of all the different actions and results during that process.

I’m out. When I tried to replace the battery I cut a FFC connector of the screen. It’s just not meant to be repaired… Threw it in the trash. But great to hear that vewifi works more or less on velte, congratulations!

Sad to read that your device is out…

Yes, that’s a shame. Opened one myself once, some time ago, but it’s indeed a tricky business.
About the update, once I found the update-file, removed the device check and executed it manually in twrp, everything is fine. Device is on latest update now and still working fine. Still studying on easier solution. Looked into build.prop. To my surprise the device-id’s are the same as in the update-check, so absolutely no idea, why the check is failing, where the t819 id in the error message is coming from and how to solve that. To be continued.

This method worked for me on the gts28velte. See that thread.

1 Like