Bluetooth Sound on Teracube 2e

I just got my Teracube 2e from E Foundation yesterday and working through getting familiar with it. One thing I have not been able to do is to get sound to go through Bluetooth. I’ve tried this with both my car and a pair of TREKZ AfterShokz headphones. They both pair. The phone says it is sending the sound through the Bluetooth connection but it always goes through the speaker. The Bluetooth connection is legit because all of the car controls actually work it’s just sound won’t go through. I’ve tried going through the sound control and toggling between phone and headphones. I’ve tried toggling “Media Audio” under the Bluetooth controls as well. Both of those seemed to be suggestions that worked in the past to get this working but in this case it didn’t do anything. Physically connecting headphones did make it go through headphones but the prompts in the app (Spotify) said it was still going through Bluetooth even though it was not.

1 Like

An update. I thought that the phone had the most updated /e/os version but it turned out it did not. When I went to system updates there was a 0.17 that could be installed and a 0.18 that could be downloaded for install. I guess that means I was running 0.16 before that (the one it shipped with). Once I installed 0.17 the sound started working as expected, giving me full control over Bluetooth sound streaming. When I updated to 0.18 the sound continued to work. So all is well once the OS Is fully updated.

1 Like

I have a similar issue with the last 18 version.
First my bluetooth headset worked like a charm … until I plug a jack headset !

Since this, calls sounds are still correctly sent to BT headset … but the multimedia sounds are sent to the speaker (tested with netflix, deezer, …).

I tried to:

  • select the bluetooth device as output in volume settings
  • recheck multimedia in bluetooth settings
  • reboot

… nothing works.
Any idea ?

1 Like

It seems to be a known bug, there’s 2 open issues here: Status · Boards · e · GitLab

I got the same issue and it’s a real bummer tbh.
I drive long distances regularly and like to listen to podcasts etc via my car audio.

Please someone fix this.
I am using the last 18 version on a fresh Teracube T2e
Doesn’t work with my VW Passat 2017 (europe edition).

Thank you. Please fix it.

Same issue here with my 2e. Tried two sets of wireless headphones. I can use the headphones for calls just fine, but any media plays through the phone speakers. And the headphones work to control media (pause, fast forward, etc.) so they are connecting properly.

1 Like

Me too, just sent an email to support. Of course, /e/ OS version 1.0 has dropped, maybe that will fix it.

Should have checked v1.0 first – installing v1.0 fixed the problem.