Can I fix an error in the location service

When I am at home, my /e/ device (Moto G4) keeps locating me in a totally wrong place (always the same). I tested with different configurations, and seems to be related to wifi-based location, so I’m assuming that one wifi-hotspot around me is wrongly tagged in the MLS database. Is there a way to propose a fix?

Strangely, my Linux laptop (also using MLS) locates me correctly… :-/

Have you tried outside without wifi on ?

It works perfectly outside, with or without wifi on. Back inside, after a little while, I’m “back” at my strange location about 25km away from my real position.

What I hadn’t noticed earlier is that Mozilla Stumbler actually reports several things:

  • a red dot (leged says MLS location) which is also correctly located
  • a green dot (legen says “Wifi+cell report”) which is correctly located (although a few meters away from the red one)
  • a blue dot (with a larger circle around it) which is at the wrong location (which is also the one reported by other applications, such as Osmand)

When I turn wifi off (inside), the blue dot is now correctly located, in Mozilla Stumbler, but other apps either fail to report location, or still report the wrong one :-/

I’m confused! What exactly is that blue dot? I thought MLS was the only source of location for /e/.

Change mode to “Device only” in Settings (Security & privacy / Location).
If your device is then unable to acquire a location, you’re facing a GPS reception problem.
You can use the nice app “GPS Test” from Chartcross (com.chartcross.gpstest, available at Aurora Store), to validate & debug.

I tried the ‘Device only’ mode, it works fine. Again, I think I nailed down the cause of the problem to Wifi…

That being said, the problem seems to have disappeared, at least for now… I’m not sure yet, because it already happened in the past that my location would be temporarily good before jumping back to the wrong place, but this looks pretty stable now…

May be with all the tests I did, Mozilla Stumbler sent the correct info to the servers? (It says that one report was sent)