Can no longer use MS Teams after upgrading FP4 to /e/ 1.13

Dear community,

I’m running /e/OS 1.13 on my Fairphone 4 and since the last upgrade, I can no longer run Microsoft Teams (don’t say a word, I’m not happy about that, but that’s how it is :wink:).

Our company requires us to install the app Since the last /e/ OS upgrade, I can no longer login with my company account. Within the MicroG SafetyNet settings, I see the error CTS profile does not match.

Does anybody else have the same problem?

Thank you :wave:t2:

Same setup here, but teams is just fine :blush:

Thx for your reply!

Could you please share a screenshot from your company portal’s SafetyNet attestation? This is mine:


Do you delete Advanced Privacy for MS Teams ?

What do you mean by delete Advanced Privacy? :thinking:

In Settings > Advanced Privacy > remove trackers for MS Teams.

I’m not using this particular feature of /e/ OS. Nevertheless, I disabled blocking trackers for both MS Teams and Company Portal, but it is still failing.

Did you kill the app in background too ?

Yes, I even tried a reboot.

I’m also using Shelter to run both Company Portal and Teams in Android’s work profile - don’t know whether this is relevant, at least it has been working this way for month.

there is a problem withi Microsoft SSO recognized as tracker, maybe you find the following link useful:


Thx @Arlytix, but Advance Privacy is disabled on my phone:

Hi @mu88 Can you please check the latest version of Microsoft apps and update?
We have a report that latest version works.

@Shenol I’m using the following versions, which, according to AppLounge, are the most recent one:

  • Company Portal → v5.0.5926.0
  • Teams → v1416/

I’ve also disabled blocking trackers in AdvancedPrivacy of the work profile, as well as completely turning of AdvancedPrivacy at all - still no luck :frowning:

What error are you getting exactly? Does a code appear?

If I remember correctly, it seems to me that the login is via browser, try clearing browser data and cache if possible, try disabling any plugins installed in the browser.

Is it possible that your company’s authentication process requires Microsoft authenticator to be installed?

Please have a look at the very post in this thread: within the MicroG SafetyNet settings, I see the error CTS profile does not match.

The error in the app is just like you’re device is not secure.

The login within CompanyPortal happens in an embedded browser, that’s correct, but not an external one for which I can clear the cache. I’ve deleted all cached data of both Teams and CompanyPortal several times.

And you’re right, our company requires a second factor via TOTP, but I’m not using the Microsoft Authenticator but a FOSS app. Since this worked before, the entered TOTP during the locked gets accepted and the underlying algorithms are the same, this cannot be the problem though.

Please install Yasnac and post the output.

You should consider to reflash the last update of /e/ os and hope it will fix the cts profile issue:

If not, have a look at this thread:

This is the YASNAC output:

  "apkCertificateDigestSha256": [
  "apkDigestSha256": "fNhMGaqoDnZ0mL1WuwwiU7RN4H+lWm/gwbLAsTAHOyU=",
  "apkPackageName": "rikka.safetynetchecker",
  "basicIntegrity": true,
  "ctsProfileMatch": false,
  "evaluationType": "BASIC,HARDWARE_BACKED",
  "nonce": "NjA4OWFkMjktNTQzOS00NzQxLTkwN2UtMzI0NzU2YjM4MWYyCjIwMjMtMDgtMTlUMTE6MjQ6MDAuNDYzKzAyOjAwCkZhaXJwaG9uZS9GUDRlZWEvRlA0OjEyL1NRM0EuMjIwNzA1LjAwNC9lbmcucm9vdC4yMDIzMDcyNC4yMjU1NDI6dXNlci9yZWxlYXNlLWtleXMKMzIKMjAyMy0wNi0wNQo=",
  "timestampMs": 1692437040698,
  "deprecationInformation": "The SafetyNet Attestation API is deprecated. It is recommended to use the Play Integrity API:"

Try the new /e/ os version and make sure bootlaoder is locked

There is no newer version than 1.13-s-20230724313396-stable-FP4 which I’m already running on.

Furthermore, according to the following developer setting I’d say that the bootloader cannot be unlocked and therefore should be locked: