Cannot see files on my GS290 from Ubuntu laptop with USB cable

I want to download the photos taken on my GS290 to my Ubuntu Laptop.
The laptop detects the GS290 but it says “Folder is empty” (I can’t see the Photos folder or Music folder or anything)
How to fix that? Are there some drivers to download? Thanks

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @Cyr welcome

You have to organise your USB preferences on the device after you plug in your USB cable.

Ensure you have no screen lock about to come on, plug in your USB cable, then, Settings > Search settings, for USB preferences, select File transfer.

Now your PC /laptop should see the device.

Edit, not always! If the options are greyed out, then search settings for Default USB configuration, set this for File transfer, then carry on to check that USB preferences are File transfer.

1 Like