Cannot share contact via SMS

I recently discovered I couldn’t send contact details via SMS. The option doen’t appear. There’s no problem via Whatsapp and emai’.
Does anyboxy else have this issue?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


It seems that Contacts doesn’t allow to (even by “Settings > Share all > Select one”). Why?

/e/ staff removed gg-calls, I don’t know how works ‘sharing by SMS’ function.

PS : from SMS > ’add a file’ checkbox you certainly could Share info about contact (just the phone number, you have to add the name by yourself).

Hi tomgey.
I proposed to add this feature here

My grandfather always said:

“Mieux ? Trop bien…” (‘Better ? [it will be] too much’).

[off topic]
KISS is always the best way because the less RAM you need the more battery you save. ‘Copy’ works almost all around /e/OS so you can share all what you want with just a few ‘clics’. Is a new app really needed here?
Antoine de Saint-Exupery wrote something like (poor translation):
“Perfection comes when there’s nothing more to remove.”
[/off] :wink:

With my MiMix2, official Pie build, I can add a contact to a message within Message app (using the + sign).

Thanks a lot, hope they’ll fix it ! :+1:

I completely agree with you on the phylosophical side of the matter. And thanks for underlining the battery aspect I was not aware of.

On the other side, if I want to pass details via SMS - or I’m even forced to, since the recipient is an elder who can use SMS only -
the copy/paste procedure, albeit working, is very inconvenient.

Go to contact
Copy name
Go to SMS
Paste name
Go to contact
Copy number
Go to SMS
Paste number
Go to contact
Copy address

I’m not so sure about the battery life with all those copy/paste loops

There’s another aspect to consider. All my friends know my position about privacy and e-phone. Just right this morning I had to send a contact via SMS and I patiently go to the procedure above.

The recipient was surprised that I was not able to send the entire vcf.

I explained him that it was not possible with
my phone and I had to stand his irony on the inability of open source software to accomplish simple tasks such as sending vcf through SMS.

I’m used to this kind of irony, since I’m a linux user since Ubuntu hardy heron, but I think the lack of similar simple features may keep people away from e-phones.

Maybe you could use Signal as your default SMS app since Messages isn’t set to receive a vcf file. I hope you will proudly be able to send your vcf file to your friend.

After a few tests, I’m not sure that’s a ‘Messages’ issue. Using Silence, the ‘add a file’ button > Share contact Infos shows only the phone number, writen 123-456-7890. Same with ‘Lineage for microg’ 14.1 (nougat, for Surnia too).

When the same device (Moto e 2015 Surnia) ran RR-oreo, Silence could share *.vcf…

(Debian Buster + Xfce4, @home :wink: )

Thanks. Also to Anonyme. I know I can use Signal, but I prefer to keep the two worlds apart.

Still learning

Good news, it’s possible ! Go into Message, choose a conversation, click on the “+” sign on the bottom left and click on “Attach a contact”.

Right, I hadn’t seen it!
Did it come with the last update?

No, my phone is 2 months behind.

So it may have been there for a while and I didn’t see it…

1 Like

May be that on 0.13 there’s a regression. The “+” button is there, you can add the contact, but the phone (S8 Samsung) keeps on sending for some time, then it fails

It worked for me. I selected the + sign, sent the contact card and the recipient received it.

I used the + sign within messages to attach/add a contact and sent the contact that way and it worked. It would still be better if it were also an option to share the contact via sms within the contacts. If anyone else can shed some light that would be great.