Cannot switch on my A5 running /e/ anymore

I’m using /e/ on my A5 2017 for a while and quite happy, with a version similar to e-0.5-n-201906xxx-dev-a5y17lte, but unfortunately it does not power on anymore ! Very strange, as I bought the phone 6 months ago (not a used one). I just put it off during 2.5 weeks as I was not expecting to use it… bad luck today !
The display remains off while wall-plugged
Also nothing happens while plugged on my PC: no usb connection or sound
In both cases, there is no temperature increase
All cables and adapters changed, same results
power+volume down + home (or similar commands) do no change anything.

Any advice ? I cannot find anything similar in the forum. Are you aware of such troubles with /e/ OS ? I believe my battery is dead, isn’t it ?

I don’t think it’s e related issue. I think the batterie is deep dry. Have you tried loading a longer time ? Sometimes after 1 or 2 hours on charger the device come back to live.

Agree with @harvey186 I have had the same issue which smartphones I have not used for a couple of weeks. They run totally dry and then simply refuse to start. Guess you will need to check on the phone manufacturer website how to recover the device. Usually they ask to keep it connected for a long period of time to start the charging.

Thank you for your replies. Tried to keep it connected all night long, same trouble.
It seems to be hardware related, I will see how I can replace the battery