Cant add e account to phone, on r-beta

I get login incorrect, check username and pw… cant attach txt or pdf so heres debug log— Nope wouldnt allow it. LMK if needed and we’ll figure it nout… Meanwhile the account… is it due to the version I have installed? R beta

Android version: 11 (lineage_chiron-userdebug 11 RQ3A.210805.001.A1 eng.root.20210831.210233 dev-keys)
Device: Xiaomi Mi MIX 2 (chiron)


  • List item

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Works fine for me, same device and Android version (0.18 R).

Can you login OK on webpage?

Sure you must have tried using your address as well as @j.son ?

yes, I can login on the ecloud. Although for a while yesterday I was getting cant update list, meaning list of emails. Not sure why that was but its back on the ecloud site. Phone still tries but ends at cannot connect to server… I’ll add that I’ve used Orange Fox recovery throughout my use of e. if you think that might be involved

I don’t think the recovery would affect things.

You could try resetting e drive app. Go to Settings, enter “/e” in search bar which should reveal the app, clear cache and storage. Optionally restart phone. Try again. :crossed_fingers:

No better. Although it doesnt seem to time out, just stays on Please Wait retrieving account information screen… Cleared both and restarted
Can I download and reinstall the app individually, and delete the existing one?

No, it’s a system app.
Running out of ideas beyond factory reset or a reinstallation.

How long have you been on this version and how did you arrive at it? Was it an upgrade from Q, or an ota from the previous R version?

Edit: No need to reply to that; I’ve just read your installation post!! Bit chaotic. :wink:

I read someone used the installer in Ubuntu and that fixed it, I could try that, I’m not to far into this build… Any idea about r release? I’m assuming only Q would be offer thru the installer

I don’t have any experience or knowledge of the installer, sorry.

Going back a bit to when you ended up downgrading accidentally to Q on eos. You then presumably installed the R version you are now on. Did you format data before sideloading it I wonder? If the answer is “yes”, I would say there is either something wrong with the installation (somehow) or (less likely) something wrong with e-0.18-r-20210831.

Personally, I’d try reinstalling the same eOS that you have now by following the instructions for wiping and formatting data before sideloading the os (not forgetting to set usb debugging, remove pin/pwd etc first). Maybe even try the e-recovery.

Yeah, on r now, I installed from OF recovery, after formatting data I used an otg cable/usb drive to do the install I believe. I’ll try the e recovery this time when I do. Thanks for your suggestions…
BTW, the installer recognized my phone but said it wasn’t a supported device. Guess it needs an update

What’s that orange fox? recovery based on twrp, lot of added fun-ctionality

Actually, since you installed eosR Doesn’t the e-recovery come as part of the process like it does on most other devices? So you could manually boot the e-recovery (pwr and vol up) and install through that as a sideload (as per instructions)

nope, I always used my OF recovery. I came from LOS w/Microg and had OF already. But I could dl e.recovery flash it then R

Ah OK, understood. Good luck anyway.

1 Like

Alright, I figured it out…
Signed inn on the web based site, Settings->Security->Devices & sessions you enable it there then phone logged right in…