Can't upload software update

General problems with my new Gigaset GS290 phone but now I find the phone cannot install January’s update which I hoped would resolve many of the issues.

May I ask why you put this in the easy-installer category?

1 Like


I think I may be responding to this too late but I saw a message that appeared to come from you under a different heading asking me to do so.

I am very new to this community and ways of communicating so forgive me if I have not done things correctly.

Pl can you provide more details as to how you are trying to install this update. Are you trying to install it OTA, using the Easy Installer or manually.

Many thanks for responding. I was just trying to do this manually in the phone’s settings as it would not show me automatic updates. I am not technical. I did receive an email yesterday evening from esolutions shop with a fix. I tried it but that too did not work (see below).

Fixing /e/-GS290 updates

Many thanks for your /e/-GS290 purchase, we’re delighted to have you in the /e/ community.

Upon preparing the next monthly update for your phone, we discovered a bug which blocks future updates installations. In other words, your phone would remain stuck at its current version, v0.13 and you would not be able to install any future versions of /e/OS. Not good right?

We are really sorry about this. But we have good news, the team has worked on a fix that is already available, hence this email today.

Below, you will find a guide to walk you through the simple steps to fix this issue. It will only take a few minutes of your time.

Step-by-step guide

We would appreciate if you could let us know if you were able to complete the process. You can directly reply to this email.

We remain available at should you run into any difficulties or for any additional questions you might have.

We do our best to offer a great experience to all our users, so once again, please accept our apologies for the inconvenience caused.


The /e/ Team

You received this email because you signed up at and/or purchased an /e/ product.

Having trouble receiving our emails? Please add to your contact list.

Unsubscribe - Unsubscribe Preferences

Welcome to /e/

Could you point us to the guide and tell us where you’re got stuck? Maybe this help to identify the problem.

PS: I’m not a member of the official support team, but i also use a GS290 and i’m interested on the solution, too. :slight_smile:

i have the same problem.

i’m running e 13 on a gigaset and no updates show up. unfortunately the solution described here (installing an more recent updater app) does not work for me:
the updater update downloads ok, but gets stuck during installing.

any advice on what to do?


I bought my phone from esolutons and although I could not tell that the updater had work, guidance from the team showed me otherwise. If you bought your phone like me, I suggest contacting them to get the same guidance. They are very good.

I meant esolution/shop.

same problem here. i bought my GS290 at /e/ shop
i did it like here:

hope the support team will help me :wink:

You can send a mail to with the purchase and issue details.

Many thanks for this. My matter has now been resolved but I will keep the email address for any other future problems I might have.

support said, 014 is skipped on stable OTA, so when everything is fine i will get an update for 0.15 next week…

We are still testing v0.15 …if the build is working well hope to release it early next week for all devices.

Is this still relevant to get updates? If so, i can’t install the update for the Updater, it gets stuck on Installing

Thank you.

Since there are already a couple of threads about this topic within this section of the forum, I suggest to close all but one, pin that thread and keep each other updated accordingly.