Contacts not showing in message app (solved)

Can anyone be of assistance to me to tell me what I am missing, or point me to another topic on this
In the Message app contacts aren’t showing up for auto fill. Contacts have synced from /e/ Drive and other apps [Mail, Viber] are auto filling ok. I have the same problem in 3 /e/ installs MotoG2, Moto G4, both Nougat and Nexus 9 LTE. Message has contacts, SMS, Storage & Telephone permissions. AOSP keyboard has contacts permission.
I have also tried Google Messages app and they are not showing up there either.

Hi @vernr that is weird. The contact list should show up by default. Can you try and clear the cache in Message App Settings>> App & notifications >> Message >> Storage >> Clear Storage & Clear Cache

Thanks @Manoj. Solved. My fault. None of the contacts imported into /e/ have mobile numbers attached to them. :upside_down_face::upside_down_face: