Default file manager (files app) does not see my USB key

Hello all,

Files application does not show me my USB storage key (in addition to the internal memory and the SD card).
I’m running /e/ on a Samsung S8 and using a Sandisk key with USB-C connector.
I validated first I can access the key from my Manjaro (not a key issue).
I tried another file manager and it cannot see the key neither.
Thus I suppose the OS is not presenting the key as a storage device.

What’s the way to let /e/ applications the USB key is a storage device ?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

As no one has dived in, I will say that when I bought my OTG Drive, which does what you require, I bought it because I thought this was the only way to connect external (Edit, as in, external to the device!) storage media. Mine looks like a tiny key with micro USB one end, 64GB core and USB 3.0 at the other end. Seen fine, worked fine. :slight_smile:

I do not have a Samsung S8, but I just tried it out on my Xiaomi M5 and it worked straight away.
I am using /e/ 0.16-q and the SD card was a 4GB formatted with fat32.
How is your SD card formatted?

According to this list Samsung S8 supports USB-OTG so it should be capable of working.

Sorry a long time without reading the answers to my post…
I could try the same key on another Samsung /e/ installed and it worked fine (Samsung S9 - Androïd 8)
However not working on my Samsung S8 Androïd 9.
I suspect the hardware for now… time to perform some test more on a more recent /e/ version.

Thanks all for your answers