[Device Roadmap] Android 9 (Pie) & 10 (Q) : Test builds to support new devices

The build gts210vewifi works for me. :slight_smile:

2 Likes

Running like a breeze on my Lenovo tablet (YTX703L)
As a launcher to get the horizontal view i can recommend Total Launcher.


1 Like

ps @Manoj i used I used TWRP 3.3.1-0

1 Like

Z3 Compact and TWRP 3.0.2-1

Note before reading : I am french, first try installing a alternative ROM (so technical english can be difficult for me to understand)

I tried to manage e/ installation and I was on lineageos unofficial 17.1 (Q android). Impossible to manage the installation ; error message E3004 “this package is for device: z3c; this device is .”

I find few posts on the internet with the same error but no solution mentioned (or not understandable to me)

I will be happy to try the e/ if anyone as an idea ?

Now back to my back up

Many thanks

Hi @Rik Was this TWRP for your smartphone …which ROM did you test?

hi Manoj, no the TWRP was for my tablet, see here , the ROM i tested was the build above in your first post in the thread for the YTX703L
For my phone I reported the TWRP here, device is a3xelte, the ROM i tested there was the a3xelte ROM in your first post of that thread

PS still running both and both still running (very) smoothly

Thanks @Rik I wanted to run a test to check if the next builds can be delivered OTA …will run a build for the YTX703L and the a3xelte and later you should get it OTA. Wanted to check if OTA will work on these two devices before setting it on for all the 48 device builds.
You should see a build update OTA in a few hours.

1 Like

cool! i am very happy to be your guinea pig on this :slight_smile::slight_smile:

:slight_smile: Thanks @Rik …Pl can you check if your devices shows an OTA update it should have the test tag to it and pie version tag.

1 Like

hi Manoj, sorry the updates are not showing up, on neither device, also not after refreshing and a restart

Thanks for letting me know will have this checked.

1 Like

Hi @Rik,

I restarted the OTA server. Could you please let me know if you are now able to see the update? Thank you in advance!

nope still the same result, also after a restart and manual refresh

ASUS Zenfone Max Pro M2 - X01BD

VERSION TESTED:

e-0.9-p-2020072263916-test-X01BD

WHAT WORKS:

VOLTE, Call, Text Message, WiFi, HotSpot, Mobile Data, Bluetooth, GPS, Camera, Flash, Turbo Charging, FM Radio.

WHAT DOES NOT WORK:

  • Torch app is missing.

  • /e/Drive sync is not working. Files, Documents and Pictures are not syncing with /e/Cloud. But Contacts, Calendar, Notes and Tasks is syncing perfectly.

  • App store sometimes fail to download apps.

  • Bliss Launcher sometimes creates two launcher icons (Duplicate Icons) of single app, removing one icon leads to uninstalling the whole app.

  • Some icons in system settings are missing, e.g. Location, Phone and Storage Permission icons in App Permissions window.

  • Banking apps do not work due to rooted device status. On LineageOS + MicroG those Banking apps work fine.
    Note:- Magisk has not been flashed.

I would love to see this phone getting official support for /e/OS. So please do tell me if there is anything else I can help you with.

1 Like

Thanks for helping out with the testing @Rik I just restarted the build. Once it is done will let you know and you can test if the OTA is working now.

Update: @Rik Pl can you check if the OTA builds are showing up on your tablet and phone. The builds are complete and show as published on the OTA server.

1 Like

Thanks for testing out the Asus phones was worried as there was no feedback on some phones. Pl can you share the TWRP version used if any.
The issues you have shared are generic and most have bugs raised in gitlab for them. So they would be there in most devices and the fix here possible will also come for all devices.

Thanks for replying. I have 2 android devices - Moto G4 (athene) and ASUS Zenfone Max Pro M2 (X01BD), among which athene was already supported for a long time now and was the first device for me to try out this awesome /e/ System. I wish I had more devices to test out /e/ on but for now I have X01BD.

I would like to thank you guys for creating and maintaining /e/ for so many new and old devices, /e/ is the best if not the only option to get security patches and version upgrades on years old devices which is one of the major drawbacks of android vendors. So I am glad to help anyway I can. I really want to see this ASUS Device to get official support.

TWRP Used for Flashing:

twrp-3.4.0-0-X01BD.img

I am looking through gitlab now for possible workarounds for the mentioned bugs. One thing I noticed last night is that not only /e/Drive is not working but Notes are also not syncing anymore although it was working the day before yesterday. I managed to take a screenshot of the error toast message.

On same version of rom, so I am guessing it has something to do with the cloud, maybe it’s temporary server issue? Let me know if you figure out anything.

1 Like

Pl check if the issue persists after some time. If it does pl create an issue on Gitlab with some logs.

nope, still shows no updates, also after a restart and refreshing the update screen

ok will have the team look into this on Monday.

1 Like