Device Roadmap : Pie , Q and Beyond - Part III - Test builds of new devices

:slight_smile: Thanks @Rik …Pl can you check if your devices shows an OTA update it should have the test tag to it and pie version tag.

1 Like

hi Manoj, sorry the updates are not showing up, on neither device, also not after refreshing and a restart

Thanks for letting me know will have this checked.

1 Like

Hi @Rik,

I restarted the OTA server. Could you please let me know if you are now able to see the update? Thank you in advance!

nope still the same result, also after a restart and manual refresh

ASUS Zenfone Max Pro M2 - X01BD

VERSION TESTED:

e-0.9-p-2020072263916-test-X01BD

WHAT WORKS:

VOLTE, Call, Text Message, WiFi, HotSpot, Mobile Data, Bluetooth, GPS, Camera, Flash, Turbo Charging, FM Radio.

WHAT DOES NOT WORK:

  • Torch app is missing.

  • /e/Drive sync is not working. Files, Documents and Pictures are not syncing with /e/Cloud. But Contacts, Calendar, Notes and Tasks is syncing perfectly.

  • App store sometimes fail to download apps.

  • Bliss Launcher sometimes creates two launcher icons (Duplicate Icons) of single app, removing one icon leads to uninstalling the whole app.

  • Some icons in system settings are missing, e.g. Location, Phone and Storage Permission icons in App Permissions window.

  • Banking apps do not work due to rooted device status. On LineageOS + MicroG those Banking apps work fine.
    Note:- Magisk has not been flashed.

I would love to see this phone getting official support for /e/OS. So please do tell me if there is anything else I can help you with.

1 Like

Thanks for helping out with the testing @Rik I just restarted the build. Once it is done will let you know and you can test if the OTA is working now.

Update: @Rik Pl can you check if the OTA builds are showing up on your tablet and phone. The builds are complete and show as published on the OTA server.

1 Like

Thanks for testing out the Asus phones was worried as there was no feedback on some phones. Pl can you share the TWRP version used if any.
The issues you have shared are generic and most have bugs raised in gitlab for them. So they would be there in most devices and the fix here possible will also come for all devices.

Thanks for replying. I have 2 android devices - Moto G4 (athene) and ASUS Zenfone Max Pro M2 (X01BD), among which athene was already supported for a long time now and was the first device for me to try out this awesome /e/ System. I wish I had more devices to test out /e/ on but for now I have X01BD.

I would like to thank you guys for creating and maintaining /e/ for so many new and old devices, /e/ is the best if not the only option to get security patches and version upgrades on years old devices which is one of the major drawbacks of android vendors. So I am glad to help anyway I can. I really want to see this ASUS Device to get official support.

TWRP Used for Flashing:

twrp-3.4.0-0-X01BD.img

I am looking through gitlab now for possible workarounds for the mentioned bugs. One thing I noticed last night is that not only /e/Drive is not working but Notes are also not syncing anymore although it was working the day before yesterday. I managed to take a screenshot of the error toast message.

On same version of rom, so I am guessing it has something to do with the cloud, maybe it’s temporary server issue? Let me know if you figure out anything.

1 Like

Pl check if the issue persists after some time. If it does pl create an issue on Gitlab with some logs.

nope, still shows no updates, also after a restart and refreshing the update screen

ok will have the team look into this on Monday.

1 Like

Ok, looks like I finally figured out what’s going on with the eDrive sync. So while adding /e/ account in Account Manager it automatically sets the server to https://e.email instead of https://ecloud.global causing to Drive not syncing. This is still just a guess as I know we can access /e/ Nextcloud services from https://e.email as well. But after manually changing the server to https://ecloud.global Drive is working as expected.

A more interesting find is that Photos and Videos captured in android device were automatically uploaded to the cloud without any issues, it just was not downloading anything to the device. Package List and Application Settings in Devices folder were also syncing accurately. Anyway it’s working now with https://ecloud.global set as server.

Hope this helps in future builds.

1 Like

Would a tablet Samsung SM-T719 suitable for eOS ? And most of all, would be useful for the community? I’m going to buy one and I would like to make the right choice.

Have you posted this on Gitlab? will be helpful to the devs

buy a tablet that is already on the list!!

That’s exactly why I’m asking ! On the list are reported two Samsung, but I cannot decipher properly the model.

“gts28vewifi” for example. If I search for it, I only get URLs from lineage OS, but no references to the exact model

The image above comes from a site which compares Samsung models.

Are those all equally suitable for eOS ?

Edit. SuzieQ, some posts above, cite a SM-T815

Update of the List of LineageOS supported devices :

New supported devices :

Asus ROG Phone 2 (I001D) : 10
F(x)tec Pro1 (pro1) : Pie
Sony Xperia XZ2 (akari) : 10
Sony Xperia XZ2 Compact (xz2c) : 10

1 Like

I’m new to gitlab, so a little lost where to post about it. Can you link me the exact page where I can submit the issue? I am seeing 12 branches of eDrive project but none of them seems to be the version shipped with the test builds.

On Gitlab this is where you post any issue.

1 Like