Drivers for s9 plus on windows 7?

Hi Community!

I just bought a S9+ so I could use the Easy installer.
I went trough all the steps in the Easy installer but the Easy installer can’t find my device.
It say that I need to install drivers beforehand, and I have tried in many ways, for example these ones:

The link that was provided in the installer points to instructions for windows 10.
I’ve tried to find “Google, Inc. - Other hardware - Android Bootloader Interface”
But I don’t seem to find the right one.
So, could someone please give me a easy to follow way to install the right drivers on windows 7?

And what mode should the phone be in while the easy installer tries to find the phone? Just normal?

And when I install the drivers how should the phone be connected?

1: Normal?

2: Download mode? ( “Power” & “Bixby” & “Volume Down” )

3: Recovery mode? ( “Power” & “Bixby” & “Volume Down”, then, “Power” & “Bixby” & “Volume Down”7sec followed by “Power” & “Bixby” & “Volume upp”

(4: Bootloder??) ( “Power” & “Bixby” & “Volume Down”, then, “Power” & “Bixby” & “Volume Down”7sec followed by “Power” & “Bixby” & “Volume upp”, then, choose bootloader + “power”)

Specs:
Samsung Galaxy S9+ SM-G965F
Windows 7

Did you try to enable “developer settings” on s9? (Tap for 7 times “build number” on settings) After this step connect the phone on pc and check if pc recognised it.

Yes, and I followed the other usb settings and a extra setting that required a factory reser (I don’t remember what it was called but it had something to do with bootloader or something similar), then I had to do all the settings on the phone again.
My pc finds the phone, and I can browse the maps on it, when it’s on normally and in download mode I see it but with another name.

I expect Easy Installer to come complete and ready to go.

Please could you try to show us that error message.

Perhaps you could see if Easy Installer saved a log, and share that as indicated in this post Howto troubleshoot issues with the easy-installer

There is one thing to rule out. /e/ supports this list of S9+ models

Models Supported
SM-G965F
SM-G965F/DS
SM-G965N
Other models are not supported

Source: Info about Samsung Galaxy S9+ - star2lte

I guess what I need is the right kind of drivers, that would be:
“Google, Inc. - Other hardware - Android Bootloader Interface”
But I cant find them in optional drivers in windows update on Windows 7, is there a link to them for windows 7 or other drivers that will work?

But here is some links to the log files:

hastebin

I got 10 of what seems to be the same kind of logs.

The problem seems to be in these parts, that seems to correlate to my computer don’t seem to find any ABD interface( and CDC serial and SAMSUNG_ Android Drivers):

2022-07-10 16:05:11,206 INFO [JavaFX Application Thread] e.e.i.c.s.DeviceDetectedController [null:-1] startDetection()
2022-07-10 16:05:11,208 INFO [Thread-32] e.e.i.t.DeviceDetectionTask [null:-1] runADBDevicesCmd(C:\Program Files\easy-installer\bin\adb\adb)
2022-07-10 16:05:11,209 DEBUG [Thread-32] e.e.i.m.Command [null:-1] command: [cmd.exe, /c, ““C:\Program Files\easy-installer\bin\adb\adb”, “devices”, “-l””]
2022-07-10 16:05:11,215 INFO [Thread-32] e.e.i.m.Command [null:-1] Command’s Process started
2022-07-10 16:05:11,295 DEBUG [Thread-32] e.e.i.t.DeviceDetectionTask [null:-1] raw shell outputs =
2022-07-10 16:05:11,295 INFO [Thread-32] e.e.i.t.DeviceDetectionTask [null:-1] Waiting

Please can you clarify the exact model of your device. Thank you.

Edit
I do see you already said

Samsung Galaxy S9+ SM-G965F

I should have asked for the devicecode, sorry. On a Samsung this is usually revealed on the Recovery mode screen. In a format like “star2lte”.

It can also be found using an app such as AIDA64.

Know your hardware - Samsung

star2ltexx/star2lte
10/QP1A… (and then a lot of numbers, do you need them too?)

We have experts on Easy Installer …

… in light of this I will just point you to this post Easy installer incorrectly reports /e/OS compatibility where Easy Installer seemed unable to recognise an hero2ltexx.

afik … the xx suffix goes back into history …

I would be inclined to think that it might be worthwhile to Report an issue against Easy Installer, best if you can include the log … if you wish to take it further.

Meanwhile … what is your feeling about pursuing manual instructions Install /e/ on a Samsung Galaxy S9+ - “star2lte”?

I do understand that you need to get your Windows 7 drivers sorted out for adb … we could return to that.

Edit, as your device seems to be displaying slightly unusual behaviour, I wonder if you would like to share a photo of your Download or Odin mode screen?

I guess the manual installation will be an option, but it seems like a couple of days of work just glancing trough the material, it would be best if we got the easy installer to work, but as a last option I guess I have to do it manually.
I would also like to take the opportunity thank you for all the help this far.

Wile clicking trough the links I found my way to:
https://adb.clockworkmod.com/
I installed them to the computer, but it made no different, and the new log, seem the same.
Shall I install them on the phone too somehow? (trough the “let me choose a location on the computer” menu) And in what mode in that case?

The phone is probably fine; and did you already Enable USB Debugging and OEM Unlock.

I really do not know if Windows 7 being end of life has got anything to do with your issue.

With this phone I would not expect you to take any special steps. Perhaps we could look at a fresh start with adb. Installing adb and fastboot on Windows PC.

Once you feel you have that all sorted … we get to communicating with the phone. Start with the regular phone mode and try to follow something like this:

Quick test to check that Windows can use platform tools with your device

Connect the phone to PC with usb, and open a Device Manager window.

You will know you are looking for a :warning: against any connected device which has a driver problem.

If you have the :warning: run Windows Update, ensure the warning clears.

Boot into Recovery mode, Device Manager still open.

Use the command adb devices (this will take no action, it only checks that you have successful communication in Recovery mode).

Use physical buttons to boot into Fastboot mode.

Use the command fastboot devices (this will take no action, it only checks that you have successful communication in Fastboot mode).

Should the :warning: appear at any stage - Windows Update again.

Now you know you have two way communication and can pick up your install instructions.

This is the sort of workflow that I expect to work without issue with a current Windows system.

in normal and in Download mode my pc finds my phone, but not in recovery, and when I try “adb devices”, it say that api-ms-win-crt-convert-l1-1-0.dll is missing, so I downloaded it, put in it the right folder, but nothing, so I put it directly in platform tools, then it askt for api-ms-win-crt-convert-l1-2-0.dll instead.
?

At least both those errors get lots of hits in a search !

So should I keep downloading these? And should I put them in the Windows folders or directly in Platform tools folder?
Or are these signs that something else is missing/ done wrong?

I gave up on Windows >20 years ago. Some of the guides I read included restart the computer, and reinstall the software. Maybe this could be the fundamental cause of Easy Installer fails??

Or perhaps this is just the nudge you need to change to Linux. :slight_smile:

I have plans to buy a cheaper computer for tails or something similar, but not right now, and Linux doesn’t catch me as an OS with less coding and fixing stuff for yourself ;)…
But my computer now, and probably my future main computer will most likely be windows do to comparability with most programs, and because I know it better.