/e/ browser won't connect to self-signed webserver

I’m trying to connect to a webserver on my internal lan using https. The webserver uses a self-signed certificate. The /e/ browser refuses to connect and doesn’t allow you to add an exception to load the site anyway. Is there a hidden setting that would allow the page to load?

# This site can’t be reached

The webpage at **https://website.mylan/** might be temporarily down or it may have moved permanently to a new web address.


Try to search chrome://flags/ about certificate.

Thanks. There is a setting to “Allow invalid certificates for resources loaded from localhost” but none that allows invalid certificates for other hosts.

I don’t know if Chrome relies on Android database, but i could worth a try to import your CA certificate in Settings/Security & privacy/Encryption & credentials.