/e/ hanging on boot, discobot confusing me

Have been using /e/ for a few months, recently did an update. Battery ran out and system hanging on e symbol on restarting. Tried cold restart with same result. Looking for help with this issue. Prompted to sign up to community. Encountered Discobot. Do not understand what that is about at all. Still looking for help please.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Discobot is a bot in Discourse forum trying to help you with your first steps in the forum (i.e. some kind of interactive tutorial).

Regarding your problems with starting the phone: maybe you try to manually install the OS again.

1 Like

Thanks for your answer.
Will reinstalling wipe my data?

only if you wipe /internal storage or /data witch is not needed.

boot to TWRP, use the install feature, naviguate to /data/lineageos_updates to find you missed update file

1 Like

Thanks piero, I’ll give it a try.

I have booted into TWRP, selected install and navigated to /data/lineageos_updates

but the directory is empty

any suggestions welcome please

The procedure may depend upon the device you’re using.
I’d download the OS you find linked on Get Support - e Foundation - deGoogled unGoogled smartphone operating systems and online services - your data is your data onto your SD card and install it in TWRP. (That’d be at least the procedure for a FP 2). You’ll find documentation along with the OS download.

Thanks ff2u, I’ll give that a try.

1 Like

Select .ZIP file type, not .IMG


Download the latest .ZIP first and then install.

Hi piero, I have downloaded the latest .zip file and installed it using adb sideload.

(I first made a backup, including of internal storage, using the rename_media_directory_workaround).

However, the phone is still hanging at the e symbol.

I am going to try restoring the backup

Thanks for your continued interest and advice

1 Like

I have sometimes seen these symptoms on other devices. They can often be fixed by formatting (not just wiping) the data partition. Steps as follows

  • In TWRP
    • backup your current data partition to SD card
    • Format data (from the Wipe menu)
    • Install the new zip (from the Install Menu
    • Wipe cache and Dalvik (from the Wipe | Advanced menu)
    • Reboot system
  • On the newly booted system, go through first time setup, including any screen pattern
  • In TWRP, restore your data partition from e backup you made earlier

I hope that helps - good luck!

Hi petefoth, thanks for your advice.

Formatting data did get me out of the hanging loop and allow me to reinstall a fresh image file.

I was then able to run through the first time setup and reboot into TWRP.

Attempting to restore the backup brought me back to the hanging situation however.

Running through this process again I noticed a warning:

“WARNING: This /data backup was made with f2fs file system! The backup may not boot unless you change back to f2fs.”

Attempting to rerun the data format and change the file system revealed that f2ff was not an available file system on the installed version of TWRP, only FAT and various flavours of EXTfs.

As this is the same version I used to make the backup, I am a bit confused.

Pausing my efforts to restore the data backup, I reinstalled /e/ once again and tried to use the system to update TWRP in the hope that a later version would support f2fs, to find that Apps would not install any new apps or app stores and kept stopping.

Attempting to download .apk files using the Chrome browser did not work either, with the download dialogue reporting “sdcard not found” (despite having ample space on internal and external storage and being able to browse files on both).

As a fresh format and clean install is not working for me, I am going to try finding and side loading an .apk of TWRP.

Any other suggestions welcome.

I do not know your device, but I would ask how important is you backup?

I would be inclined to stick with a clean install. (Speaking for myself, I often learn the hard way and have already made a mental note only to update with a full battery!)

If you really want to try to restore your backup - is there any possibility you can retrace your steps and install the image you started with [post #1] a few months ago?

It seems as if I have the most recent compatible version of TWRP and do not have the option of formatting to f2ff. I have tried formatting data on some and all partitions and reinstalled known, working images of e/ versions 15, 16 and 17 via adb sideload.

Even without any attempt to restore data from the backup, I do not have a working install of /e/, with Apps able to find Apps, but not install them.

I am able to restore contacts from sdcard using a .vcf file, and browse photo and video files on different cards so I can read cards OK.

I have installed /e/ 17 using system update from an /e/ 15 installation, which included verification, but still Apps can search for and find, but stops when asked to install.

When I open gallery, I get the message “No Storage No external storage available”, superimposed over a selection of my photographs on the external storage card! I I can play videos OK, but if I take a photo or video, I get a “failed to save” error.

Via USB, I can browse the sdcard and the internal storage, but there is nothing visible in internal storage but a TWRP directory with the .twrps file in it.

I’m out of ideas at this stage - what am I missing?

Hi aibd

the backup is very important to my wife (her phone).

Even clean installs are not working, after formatting, wiping, factory restores, sideloading…

I’m not sure if I have missed something vital, or if there is a hardware problem.

Thanks for your concern and suggestions.

That is an issue you can search for on the web. I won’t point you to one particular answer as I don’t know your device and I do not know the status of your connection with the original eCloud account.

Apps is capable of misbehaving as you describe. Have you tried to install an .apk by any other method?

Hi there

I’m not having any success searching for this issue on the web.

Her eCloud account has not been set up or used, the backup was made using TWRP onto an sdcard.

It looks as if this might relate to the sdcard being browsable but not seen by apps and internal storage not writeable by them.

Possibly that means that apps don’t have anywhere to operate, so to speak?

I installed .apk of TWRP transferred via USB to sdcard no problem.

Thanks for your suggestions.

So if you can install an .apk, you may be able to install https://www.f-droid.org/. (I would not recommend the use of TWRP.apk it will do no permanent harm but I would uninstall it.)

It is useful to know that eCloud has never been used on the device, so you are uncomplicated by partial restores from there!

One of the simple fixes for “No Storage No external storage available” is to Soft Reset or Force Stop the device.

If you were only trying to get the phone working, you could work without an SD card for a while, to see if you can get the device functional.

It might be interesting to check the free capacity of the device in Settings > Storage.

Hi aibd

I have tried to install fdroid, without success (it is the only thing I would use the Apps app for).

I get the message “SD card not found” and cannot find a way to change the default download location because clicking on downloads get the message “not enough space” (there is plenty of space, but may not be accessible for some reason)

I have tried to get the system running without using the backup or sdcard amongst many other things

  • please see above.

Internal shared storage 5.26 GB used of 14.90 GB
sdcard 10.60 GB used of 14.44

UPDATE - I now have the phone working, although I’m really not sure how. I continued to format, wipe and reinstall, trying many different approaches until finally the /e/ OS was able to write to the internal storage.

I suspect that the backed up data will need the data partition reformatted to f2ff first via adb to succeed, but after a day without use of the phone my wife is just happy to be able to make calls again and that may never happen :wink:

It may be that the “format data and reinstall” approach that was recommended allowed TWRP to reformat the f2ff data partition with EXT4 and it would have been better to use the -rm -rf approach.

As always a more careful, RTFM approach may have spared me a sleepless night.

Many thanks to all who replied, hope this is useful to others.

1 Like