/e/ installation on galaxy s9 plus can't get into Teamwin

Hi, from what you say it is not quite clear where you are stuck, but as you ask for a video, is it here?

Sorry I can’t get my phone into TWRP. This is all I get .

Is Easy Installer telling you in the log that TWRP upload was a success?, or does the log, suggest successful upload, then fail?

Are you sure you got the point made in the video about timing? :smiley:

Some more background reading:

1 Like

I have pretty quick reflexes so yes i believe my timing is very good . After having to factory reset my phone the first time and having to figure out how to Oem unlock again Iv’e tried it at least 6 times since . The installer did not do anything after i got stuck on this step .The continue button would not show in the bottom right corner. I stepped away for an hour and now it says "The installation encounter an error "

Am I supposed to let this finish before trying to get into TWRP?

No, but this shows the problem: RMM-State Prenormal.

That is definitely the problem! There is a mention in the Know your Hardware link above, last paragraph and a lot of information online.

This is what the installer shows at the moment.

Well i followed the link and another link and another link . I am now more confused then I was before . I either have to wait 7 days or try the same thing again that didn’t work in the first place

It is not easy. I think the first thing to be sure of is that you left no locks or accounts on the phone before you did the factory reset, second that a, say Google, account didn’t get reactivated on some occasion you went back and used the phone.

Then, how new is the phone, and is there is any possibility of the phone having a “Regional” lock on it due to it being sold in a different country from the one in which you now own it. Secondhand phones could have a history difficult to guess. Just a few ideas to compare with what you are reading! :slight_smile:

My eyes don’t recognize ‘the problem’ in the picture because of the blurriness. How do you recognize problem ‘RMM-State Prenormal’ please?

The phone was sealed new in the box when i received it a month ago . I was logged into google when i accidentally factory reset it the first time i tried it .

It is hard to see but it does indeed say that i believe the 4th or 5th line down

Yeah, now that you say it, I can at least read ’ Prenormal’.

@Redsidriver, you do realize that /e/asy installer tried to install eOS 'O’reo?

The phone was on Android 8 until today . After the phone went into factory reset it would not show oem unlock . So I went through the long process of updating everything and changing the date several times along with restarting the device to get Oem unlock to reappear.

Android 8 ('O’reo)?

The BIT BINARY ‘7’ is more likely a reference to Stock Android Pie (Android 9).

I tried the easy installer v0.12.2-beta on an S9 (starlte) incl. stock Android 9-Pie a few hours ago. It almost ended in a debacle. I had to completely reinstall Stock Android to get my S9 working again.

Yes its is on Android 9 now after all the updates I did today . My phone is working luckily but i have no idea what i need to do now to install the new Rom. :man_shrugging:

My recommendation is:

1.] upgrade to the latest version of stock Android 10 with security patch level 5 March 2021.

2.] then manually install Android 10 /e/ OS ‘Q’ e-0.13-q-2021012097133-dev-star2lte.

3.] and please(!) - forget about the /e/asy-installer for now, as long as it operates with 8-Oreo.

Don’t update your stock ROM anymore

I had the same issues. Please see THIS thread.

If you are in the USA and have updated the stock ROM to Android 10 (not sure about Android 9) I don’t believe you can get the RMM to normal. I have tried everything. This means the bootloader is unlocked but Knox/RMM blocks (edit: due to regional lock, non USA phone being used in USA) the TWRP flash to the bootloader. I had the same issue.

EDIT: If I could go back in time I would buy direct from the eStore or use different hardware (non Samsung).

@Redsidriver also read THIS.

If you are in the USA you are experiencing what I just went through, DO NOT UPDATE your stock OS or you will be stuck in RMM prenormal (EDIT: and you won’t be able to flash anything, TWRP or any “official” ROMs lower than Android 10 (Q), nor "non-official ROMs)

@Redsidriver, I woke up thinking, have you had a working SIM card in the phone?

Then, just looking for what you might have in common with @egx470, what part of the world are you? and was the phone sourced locally? Good luck.