E on moto g7 now installed

I just installed e on a moto g7.

I first tried OSX Big Sur and struggled to get fastboot working in the terminal so I had to install Windows 10 via Bootcamp and was able to restore the bootloader using Motorola Software Assistant as somehow the boot image became corrupted while connected to OSX.

Once on Windows 10 I was then able to proceed with the instructions on e foundation and pmoody’s community post (thanks!) to install e dev beta on moto g7.

I came back to OSX this morning and found an article that mentioned adding .\ in front of adb devices which allowed adb and fastboot to find and issue commands to the moto g7.

What an adventure but good fun!

It feels good to be de-googled but I am wondering how I can install my bank app without losing the integrity of not being connected to google. Auroroa Store seemed to solve this for any additional apps. :slight_smile:

Everything working so far in e except for notes which came up with a server sync error.

“synchronisation failed server connection broken”
java.io file not found exception


Looking forward to the non beta image which will have OTA updates.

Thank you e foundation! Great work!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I want to buy a Moto G7 power to install /e/ on it (I can’t find any G7 phones. I think in the Netherlands only the G7 power was sold), but the install doc says only models XT1962-01, /04, /05 and /06 are supported. I’m not sure but I think the G7 power has model no XT 1955-4. As far as I know, all the hardware is the same except for the bigger powerbank. Could I do any harm if I tried to install /e/ on this model number?


I am not sure if this would work. Perhaps @Manoj could advise if a moto g7 power build is in development.

Devices already with official LOS support are easy to build and will all get on the supported list. I think Moto G7 power is also supported so should be getting an /e/ version as well. Do not have the dates as yet.

1 Like

I have a Mororola G7 Power in the USA.

I will be trying on a Motorola G7 Power XT1955-2 Canadian version.

Just installed /e/ (the version found in these fora: 10QQ3A.200805.001 20201212.205157 test keys) on moto g7 power (xt1955-5) last week; metro service seems to be working fine so far, although some device issues have arisen (aside from a bad key warning whenever I start the phone… I have also messed with settings to try to alleviate these issues):

  • occasionally the screen drawing will go wacko (I just toggle setting again in displays->advanced->colors),
  • USB file transfer seems to pause for about a second after every file! so it ends up being slower than expected,
  • phone calls force the screen to go black, and it can not be turned on until the other caller hangs up… so no entry of number options,
  • I haven’t found “swipe typing” (maybe that feature is too google?), and next word suggestions don’t come up),
  • and the notification light --which I’d never seen before!-- is not responding to my requests for it to go off or at least go dimmer.

I’ll post the issues in another chat, but I wanted to say here primarily thank you! And if you’re shaving these issues, I’ll try here to link to any solutions I find…

Just realized another issue: the data counter says I’ve only used about 3GB, but my carrier warned me I’m at 9 (out of 10 for the month), and I’ve only just rseet the month last week, i.e. the counter is likely missing something…

Texts going to wrong threads
Going to try calling provider and having them reset settings…

Updated to /e/ 19 install

Without having installed the most up to date rom because it kept throwing various errors depending on how I tried), the first attempt to flash /e/-19 seemed successful, but for insufficient space errors and unlock pattern issue.

second time i tried to format and flash again I went up through the point of copy-partitions, then instead of /e/_recovery, i used twrp 3.5.1_10 to wipe as much as I could, and installed /e/-19 from there.

When i used twrp to boot into slot B, it gave me the /e/-19 welcome screen (as expected, all good), but using twrp to boot into A gives me a boot loop even though I can boot into recovery from the bootloader to /e/-recovery, which itself tells me “active slot: a”, (previously it was b), but so far no problem as long as i can get ota updates that don’t break anything…

did you sideload the copy-partitions-20210323_1922.zip script? this one copies one slot partitions to the other one, depending on which one is active. Both slots should be able to boot your userdata ideally. On the other hand - the next OTA will be applied to the inactive slot (I think I’m right here), it will catch up eventually. Depending on image, not all firmware partitions are included though, so the copy-partitions script sideload probably has them. You can also do this plainly from fastboot. YMMV - I don’t have a G7, but a FP3 has the same A/B slot scheme.

1 Like

Yeah, I did that first in order o get /e/recovery there, then when I used twrp, it was just booted (I.e. not side-loaded, afaict), and allowed me to reboot from either slot (warning me that slot A had no OS installed).

So far the last flash has held up fine, although I’m still looking for swipe/gesture typing and voice to text settings (don’t see former anywhere although I thought I read about it being a new feature somewhere around here, and for latter I must have permissions wrong because its not turning on when I click the icon… Still digging for clues)

Also maybe important update: I use red pocket, and in order to get data working, I had to call them to reset some data setting or another on their end AFTER they helped me with new APN settings (mostly similar to previous, just name change I think), which may have had more to do with AT&T dripping 3g a few days ago than my recent flash…idk