/e/ OS installation for 2022 batch of Terracubes?

Hello, I’ve been waiting patiently since January for /e/ to be released on the new batch of the terracube 2e. I see that they are back on sale in the /e/ store here, and presumably those are phones from the 2022 batch.

But, the installation instructions still have the line “/e/OS on Teracube 2e is only compatible with Android Stock 10 firmware”, which implies they are still incompatible with the 2022 batch. So, any news about this?

1 Like

:crossed_fingers: will update if there is any positive news on this

I’ve been checking both the Teracube and /e/ OS forums for a few months now every other day for updates about this without any real idea what’s going on. Today I got an email from /e/ commerce about Murena Teracube 2e’s back in stock, which means there has to be a working OS installation for the 2022 batch. Was there an update on installation of /e/ OS that I missed somewhere?

I too have been waiting to be able to use my /e/ account with the Teracube 2022. And I too have been sent notice that I can by one with /e/ preinstalled. So there must be a known procedure to flash /e/ on our 2022 Teracube. Hoping for an answer.

There are actually problems watching video on this device,
Lots of discussions here on the forum

The video thing put aside, the 2e runs pretty well with /e/ 0.22 - bought one with /e/ preinstalled a few weeks ago.

The battery life is awesome.

The fix for 2e emerald videos not working is expected to be rolled out this coming week. The issue with SD cards is yet to be fixed.

1 Like

Video problems aside (video doesn’t matter if I can’t even get the OS on the phone), are there any updates on flashing /e/ onto the 2022 version?

The flashing instructions are posted for emerald: Install /e/ on a Teracube Teracube 2e (2021) - “emerald”
I have successfully installed it and it is working fine for my needs. Thanks to the devs for making this happen.

1 Like

Same here. Just installed /e/ on my T2e emerald also. Went without a hitch.
If all goes well this will be my third /e/OS device though it will be replacing the Axon 7 which has serious battery degradation. Opening up that device to replace the battery is not trivial. After giving it the once- and twice-over via Wi-Fi I’ll see if things will work with a SIM swap.

Topic has been covered elsewhere but have to say I am not happy about not having an FM Radio app. A phone capability that will not be enjoyed. [grumble grumble].

@marcdw, do you have VoWiFi working?

I don’t know. Have not put in a SIM card yet (I assume that is needed to get the option).

I kind of messed up my installation and had to start over.

Question for you. Other than calendar, contacts, and mail, is anything else syncing for you? Like photos or documents? So far I’m getting nothing. eDrive, which generates its own logs, is apparently crashing in the background. Might be a known issue but I haven’t had the time to check.

Yes, I’m able to sync photo’s, but it seemed to take a while for it to complete.

And that’s with asking it to “sync now”.

@jc6 , is VoWiFi the same as WiFi Calling? If so I’ve never used/tried that before until today. [I had no internet at home between 2014 and 2020]

I took the SIM from my Axon and put it in the Teracube. It took right away.
Phone is already on WiFi. Switched on Wi-Fi Calling and chose “Call over Wi-Fi”.

Brought up dialer and called one of my phones. It worked and I talked back and forth to myself. :slight_smile: It stayed on Wi-Fi so I assume it worked(?). Using T-Mobile.

If that’s VoWiFi then yes, it worked.

That was cool so I tried it on the Essential PH-1 /e/OS Pie using Mint Mobile. That also worked though it took awhile before the other phone rang.


Yes, WiFi calling is what I was wondering about. Thanks for the info, glad to hear it worked.

I’m on Tmo through Red Pocket and so far that’s the only thing that isn’t working for me. I’m using the sim from my S9. I have two 2e’s, tried it with one 2e running stock Android and one with /e/ and same results. Thinking it may be to do with RedPocket not having the IMEI numbers for the 2e’s in their system. I wanted to make sure everything was working first before I take that step.

@marcdw sorry to bother, but could you do something for me?

I’m not sure yet that my WiFi calling is working on /e/.

Could you check your WiFi data usage and see if the Phone app shows any usage?

On my 2e that’s running stock android, the Phone app is in the list of apps that have used WiFi, but not on the 2e running /e/.

The other thing I noticed is that on the phone running /e/, I see the WiFi calling symbol when making a call even if WiFi calling is disabled and/or WiFi is turned off, whereas on the stock android phone if I disable WiFi calling I see the non-Wifi standard call handset symbol.


Hmm, your questions made me re-evaluate. I made what I thought was a WiFi call. Left it open for awhile then hung up. The Phone app is not in the Wi-Fi usage. I also saw the standard phone call icon.

Where I had “Call over Wi-Fi” set I tapped on it and chose “Wi-Fi only”. Any call attempts fail with the message…

So then I brought up the Network app (because I always forget the dialing codes)…
Network (Shortcut to network info and settings)
…and find that even though Wi-Fi Calling is provisioned, Voice over WiFi is unavailable. Ouch.

So from the looks of it I was wrong regarding VoWiFi. Seems it is in fact not working.
Also realized that’s the case on the Essential PH1 with /e/OS Pie and Mint Mobile. The reality is that they were switching over to cellular when making a call it seems.

1 Like

Also, same results on a OnePlus 8T, Carbon ROM, T-Mobile 5G (though not really according to Privacy Cell (Verify that a phone is using the most secure cell protocols.).

Never thought to check any of this when I was on stock.

Oh, since I have not messed with this stuff I do not know what the WiFi calling symbol looks like.

1 Like

Thanks for the info marc, appreciate the help.

I’d been using the test screen (##4636##) but I wasn’t aware of the IMS status menu.

When I checked it on the stock Android phone I got what you did; WiFi calling \ Voice over WiFi is provisioned but not available.

At this point, I’m doubting that even with WiFi connected, WiFi calling enabled, and getting the WiFi calling symbol that it’s actually working.


I found that part of the problem was WiFi calling hadn’t been properly set up with Red Pocket. After the proper WiFi calling setup was done, the stock android phone clearly shows WiFi calling is working, but unfortunately the phone with /e/ apparently still isn’t.

1 Like