Easy-installer can't check integrity on Samsung Galaxy S8+ / S7 doesn't work


I installed /e/OS on my S8+ few months ago (with easy-installer) and for some reasons came back to android.
Today I wan’t to installe /e/ again and the easy-installer gets stucked at “can’t check integrity” when downloading files.
I’m on fedora, tried on windows same thing.

FYI, concerning my Galaxy S7 (which is on /e/OS for nearly 2 years now), easy-installer tells me my device in not yet compatible…

Is there a problem I’m not aware of with easy-installer that I just have to wait to be solved or else ?

Thanks !

Hello; Could you try to remove the smartphone screen password/fingerprint lock and also to allow usb debugging in te developper settings menu ?

The phone has been reset, no password or fingerprint lock, developper mode OK, usb debugging OK, default usb to mtp etc.

same here
My S7 edge SM_G935F was working with /e/OS since 2 years. Trying to reinstall the OS from scratch the device is said “not yet compatible”.
Is there something wrong with easy-installer software ?