Easy installer doesn't find my FP3

I’ve followed instructions from Easy installer (for Linux) to the "transferring files " step, but now, it doesn’t find my phone (I’ve waited for 15 mn); I thought it was because my phone was locked; I’ve unlocked it with the code given by Fairphone, but Easy installer still doesn’t find my phone.
Yves

Not sure if the info is needed but which linux distribution are you using?

On top of my head I don’t remember which step is the one you describe as “transferring files”, can you post a screenshot of the easy-installer in that state, please?
And when the problem happens, does the phone show a screen like this (does it say “locked” or “unlocked”)?
grafik

And finally I think the log file would be helpful as described in Howto troubleshoot issues with the easy-installer

1 Like

Thank you Angel
I use Linux Mint (I had to adapt to load snap files, with your help)
When the problem takes place (not detecting appliance) my phone shows the usual screen as if nothing had been changed.!
The step I mention is as follows Capture d’écran du 2021-03-29 12-22-16|666x500
It works to that step, but afterwards it is stuck to “detecting device”.
Yves

Sorry Angel,
I didn’t know how to get to the “start” screen. (I’m a very basic user)
Now I know and it shows “device state: locked”
So it seems that the unlocking procedure didn’t work.
I’ll try again and, perhaps, ask for a new unlocking code with Fairphone
Thanks
Yves

Ok, I misunderstood how far you already got.

Is it correct that the installer hangs in the “Looking for your device” step (please ignore the window showing a Samsung device, couldn’t find a better screenshot quickly)?
grafik

I know you posted this image, but if I remember correctly there is no reason why it would hang on that screen once you clicked “continue”
Capture d’écran du 2021-03-29 12-22-16

In any case, I really think the log would be useful: Howto troubleshoot issues with the easy-installer

@yguignot I think the instruction set you are missing is this:

You can just turn off your FP3/FP3+, then press the power button and volume down button at the same time until the device vibrates. After some seconds you’ll see the fastboot mode.

There are longer instructions to get you fully in business, but is this the missing step? :smiley:

1 Like

Thank you aibd
I recently know how to get to the fastboot mode; I can see a black screen with a few lines, one in red reads “device state locked”.
What can I do then? Start from there and unlock the phone? I don’t understand much of what I’m doing, I don’t even know what Fastboot mode is… (I’m 67 and when I was young modern telephones had dials :confused:)
Yves

While it is true that this will boot the phone into fastboot mode, I’m quite certain it will not help here as the problem already occurs earlier:

At that stage the installer uses adb to determine which phone model is connected.
And that is failing.

I may repeat myself, but it would be really, REALLY helpful to see the log file…

I know you want to help me Angel, but the content of the logfile is cryptic for me; it requires programmer capabilities, not for me; I’m a very basic user (telephone, sms, mails, pictures, etc.)
what I want is to escape Google.
I could get in touch with Piero; he is OK to help me; it will be in my native language and, may be, I’ll feel more at ease to cope with these “flashing” issues.
Thank you for your help
Yves

You don’t need to read and interpret the log file yourself. Just share it to us so we can have a look. :wink:

1 Like

Sorry Angel I’m really bad at understanding all that;

I thought that the log file was the link you gave me in your message; obviously it isn’t; what is it? is it on the phone or on the computer?

I’m desperate😕

Yves

Please don’t be desperate! Small steps!

Look for the log file on your Linux PC in

~/snap/easy-installer/common

Thank you,

I’ve found it but there are 16 files of various sizes in it. I did so many attempts

Shouldn’t I erase them and restart the easy installer procedure from scratch to have a clear log file?

Yves

All the logs will be independent, so to start again is ok, but why not send two of what you have? Send the biggest and the most recent.

Are you familiar with https://haste.tchncs.de/ ?

You just open the link above, Copy and Paste your file. Save. Collect the new url, of the saved document.

Paste each url into your next post.

Hello Iain,

I had a look at the files and the biggest one is 400 times the same thing; probably because I let the program detecting unsuccessfully the device for a long period. I imagine it is useless to you.

I send you the last but one because the last one seems incomplete.

I hope you can have it through this mail; I don’t see how to send a file via the forum and I’m not familiar with Haste …; if it doesn’t work, I’ll try with that system. Just tell me

Sorry but I’m an old bloke far away from the connected world, but I don’t want to be under the scrutiny of Google, Microsoft, Apple, Amazon & Co

You’re kind to help me

Yves

(Attachment 5dcc4228-deee-4575-85e9-284b49c167e2.log is missing)

Here is the document through Haste …
I hope it works this time
https://haste.tchncs.de/kuxoqukara.php
Leaning by doing…
Yves

Oh, one important thing: the USB cable you are using, have you successfully used it before to transfer files between the FP3 and your computer?
I’m asking because some cables can only be used to charge the phone, and those would be useless here.

1 Like

Yes, it is fully operational; I already used it to transfer pictures from the phone to the computer.
When I connect it to the computer, I can see all the phone directories from the computer
That’s why I’m surprised at "easy installer’ not detecting it.
Yves

1 Like

Great, so it is just the same as you said at the start! Easy Installer is not detecting your phone!

I expect you already read the Fairphone instructions for unlocking, they are not easy to read, n’est-ce pas!

I could help you go through those instructions, step by step, (perhaps @piero would be better), otherwise I will step back for a bit, I never had a Fairphone. :smile:

I’ve just made a new attempt and the problem in still the same: stuck at “detecting device”
Attached, the corresponding log file
https://haste.tchncs.de/irabazecum.php
What I don’t understand is when I should unlock the phone: before launching “easy installer” or later on, during the easy installer procedure?
I’m a bit puzzled here. In addition, all my attempts to unlock the phone, according to the procedure from Fairphone, have failed, so far.
Thank you all
Yves