Easy Installer on MacOS not able to download latest file

Hello all,

I wanted to upgrade my FP3, still on Pie, via Easy Installer V0.17 on a MacOS 12.4 (Monterey). Unfortunately, the process fails because the “Downloading IMG-e-latest-r-FP3.zip.sha256sum” could not be downloaded.
The Easy Installer window shows the following window immediately after the download start,

.The green dot moves continuously from right to left but nothing else happens. The programme does not react when I click on “Try again”. After waiting for an hour, I interrupted the process.
Does anyone have an idea how I can solve this problem?

Many greetings
Box

The file downloads themselves seem to work currently …

https://images.ecloud.global/stable/FP3/IMG-e-latest-r-FP3.zip
https://images.ecloud.global/stable/FP3/IMG-e-latest-r-FP3.zip.sha256sum

If your issue still persists, perhaps there’s something helpful here …

Thank you for the feedback,
I was also able to download the files manually. I also tried the download via the installer again, but unfortunately it was not successful.
How can I link the image file with the Easy Installer? Unfortunately I couldn’t find any solutions in the linked threads, also because it’s not clear to me how to get to these paths, for example.

Box

I don’t know much about the Easy Installer, as I don’t use it, and I don’t have any macOS expertise to speak of, so if no macOS user can shed some light on this, then possible paths forward are either access to a computer with Windows or Linux to try the Easy Installer there, or access to the logfile to check what the actual error is in detail.

With a file explorer? Or are these folders shielded from the user by macOS?
I don’t understand from outside what exactly macOS puts where to make the Easy Installer runnable by the user, but /tmp/easy-installer at least is an absolute path in the filesystem.

Else …

Can you somehow search the filesystem for *.log (every file with a filename ending with .log) and sort the results by the timestamp in descending order? The logfile needs to be somewhere, and it should be recent.

Underneath the UI, Mac OS X is unix like, so I assume, this command in a terminal should be able to find the location the easy-installer puts it’s logfile and/or downloaded images:

sudo find / -type d -name easy-installer

Not sure if sudo is needed, but I guess running the command as non-admin-user will print lots of “access denied” messages that’ll make it hard to read the actual output. And I guess the command will take quite some time to complete.

Other than that the command searches from the top-level root folder ("/") all directories ("-type d") that match the name we’re looking for ("-name easy-installer").
As written in the other topic, from looking at the source code it should be either “/tmp/easy-installer” or “<the ‘installation’ path>/bin”

If you want to search for all log files, the command should be

sudo find / -type f -name "*.log"

If that gives strange errors, it might be necessary to try without sudo or use '"*.log"' instead of "*.log"

unfortunately i could not locate any log files. neither via macOS file search for .log or /tmp/easy-installer files, nor via terminal with all the suggested commands.
absout nothing, hmm.

I have no idea how software gets installed or run on Macs, but IIRC I read somewhere that it could help to move the installer application outside the downloads folder? Maybe into a “regular programs folder” whatever that might mean.

Thanks for the tip, I had tried that anyway. Am I interpreting this correctly that if no log files can be found, the Easy Installer does not actually connect to Murena? Is there anyone from the development team reading this who has further ideas for a solution?
Box

I don’t think so. The log starts with some diagnostics output like the detected OS etc. There are supposed to be lots of lines in the log before it attempts to download anything.

My assumption is that the rights management on MacOS prohibits to create the log file. And maybe also to store the downloads done by the installer.

I had the same issue because I tried to run the app directly from the mounted drive.
In my case, moving the EasyInstaller app locally did the trick: it probably needed to have write permissions in order to download files.

1 Like