Fairphone 3+: /e/ installation got stuck at flashing system image on MacOS

Hi there,

I am new to this forum, as I am having issues in installing /e/ on my Fairphone 3+.
After a while I figured out how to get the phone into unlocked fastboot mode, means I have the fastboot screen now and the devide state says “unlocked”, so far so good.
I am on a Mac (M1 2020, Big Sur) using the Terminal and started with the first command -w which worked well with erasing the phone.
Now I got stuck on the second command which is “fastboot flash system_a system.img -S 522239K”. I get the error message “cannot load ‘system.img’: No such file or directory”.
What I already did: I have made sure that all files from the /e/ installer .zip directory were unzipped into the very same folder where also the “fastboot” command file is stored (and all other platform-tools files), I dragged and dropped the fastboot command file into the terminal to make sure the correct directory is being used, then I copy-pasted the command “flash system_a system.img -S 522239K” (without “fastboot” since I dragged and dropped already the cmd file). But still the error occurs. I have tried to move the folder into various different directories, since I thought, maybe it has something to do with permissions or so… but nothing helps… So honestly speaking I dont know what do to anymore, since I dont understand why it doesnt find the “system.img” file, as it is definitely there in the same folder…
What about this TWRP recovery installer, do I first need to install this before I install the actual /e/ OS installer? Sorry for this maybe stupid question… I am coming from iOS. :slight_smile:

Anybody can help?
Many thanks

If you really made sure that the terminal is operating in that directory, perhaps try to put a ./ in front of system.img (resulting in ./system.img) to force the terminal to look for the file in the current directory.

Thanks for the reply, much appreciated. I immediately tried, but unfortunately without success. Please find below the terminal input and output:

dennis@Air-von-Dennis ~ % /Users/dennis/FP/fastboot flash system_a ./system.img -S 522239K
fastboot: error: cannot load ‘./system.img’: No such file or directory

Hi Denace,

It appears that ‘fastboot’ and your image file are in the same directory.

Try this: Run the command “cat NOTICE.txt” from your command prompt in the “fp” directory. It should return the contents of NOTICE.txt. Let us know.

If that works here is the command string that should work from the teminal in the fp directory: ./fastboot flash system_a system.img -S 522239K

Hi Jazz, thanks for the respond!
I have tried your ideas, but unfortunately still no success… :frowning: Find below what the terminal is telling me:

"dennis@Air-von-Dennis ~ % /Users/dennis/FP/cat NOTICE.txt
zsh: no such file or directory: /Users/dennis/FP/cat
dennis@Air-von-Dennis ~ % /Users/dennis/FP/./fastboot flash system_a system.img -S 522239K
fastboot: error: cannot load ‘system.img’: No such file or directory"

Should I maybe not have all the files in one directory/folder? However all correspondences that I could find in the web were all telling something like this to make sure to have everything in one folder…

P.S. BTW, I have also tried the following command without success (dont know if this makes sense at all…): “/Users/dennis/FP/./fastboot flash system_a ./system.img -S 522239K”

P.S.S. I have unplugged my device from the MacBook and retried the same command again as above and now the terminal is doing nothing, i.e. no message “no such file”, but also no other action, since the device is disconnected. Could it be that it has something to do with the device itself, maybe inproper unlocking state or something like that. For your info, I am trying all the commands while the phone shows the Fastboot screen, i.e. I didnt press “START” with power key, but left the phone in this screen, is that correct?

dennis@Air-von-Dennis ~ % /Users/dennis/FP/cat NOTICE.txt

cat is global binary. Prefixing with the path to FP will lead to cat the binary itself not being found.

Just cd your way (use TAB completion) to the FP directory. Then cat any text file… or stat system.img for example to see file permissions, ls -l *.img to get them of all image files.

How did all the binaries (fastboot, sqlite3, adb) end up in the same directory as the image files? In any case, ./ is a “here path” to use the binary in your current path, not a global path. If the binary (like adb or fastboot) is not installed globally, you have to prefix it with ./

Try this:
cd ~/FP
./fastboot flash system_a system.img -S 522239K


Thanks a million andrelam, this was it, though I still dont fully understand (seems that drag and drop into terminal is not always the best way)!! Also thanks to all the other repliers!!

I am now a proud user of /e/OS! :smiley: