Fairphone 3 slow

Hello,
I bought my Fairphone on e.foundation and now it is slow. It happened after Fairphone fixed my screen and reinstalled Google Android without my permission. I had to use the Easy Installer to switch to /e/ and I am on /e/ Android 10 since by the way.
Any idea why I sometimes need few seconds to open an App ?

There’s a bug report of Bliss Launcher using large amounts of RAM. This might be the reason for your slowdown

1 Like

Just wondering … Did you go through e foundation support since you bought the phone there, and then they involved Fairphone to fix the screen?
In this case reinstalling /e/OS on your phone should have been e foundation’s job.

In case of a repair under Fairphone’s warranty without involving e foundation, restoring Fairphone OS would be normal for Fairphone’s repair partner, since Fairphone explicitly only support Fairphone OS, and usually it would be the user’s job to revert the phone to Fairphone OS before getting support by Fairphone (which of course might be hard with screen trouble, so perhaps they would be prepared to being considerate).

If not under warranty, you would have gotten a quote before the repair, and if the reverting to Fairphone OS wasn’t mentioned in the quote, the quote would not have been correct. In this case make sure to give feedback to them accordingly.
Reverting to Fairphone OS as far as I can see is always mentioned in connection with the warranty (e.g. here and here), and if the warranty wouldn’t apply, then the default reverting to Fairphone OS wouldn’t apply, so they would have to mention this step to enable you to make an informed decision.

Is it under warranty so I contacted /e/ support first on Telegram about the screen and I got confused. That’s is why after some months I went to ask fairphone directly.

I restarted the FP3 but it feels the same, also I notice Shelter Apps like Waze are slower.

I guess Shelter is introducing a bit of overhead for startup times, but I’d need to measure it to be sure.

Which specific App and do you think is slow to start beside Waze? are those too in separate user profile via Shelter?

If you want to compare startup timings, youd’d need to find out the appid and possible the main activity and start if after a reboot or longer time of inactivity to discern between cold, warm and hot startups.

adb shell am start -W <appid/app-activity>

(though Shelter can use run-as flags and differ)

Here’s an example output for Signal (on a older Moto G4 Play, not in a separate profile)

~$ adb shell am start -W org.thoughtcrime.securesms/.RoutingActivity
Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] cmp=org.thoughtcrime.securesms/.RoutingActivity }
Status: ok
LaunchState: WARM
Activity: org.thoughtcrime.securesms/.RoutingActivity
TotalTime: 435
WaitTime: 440
Complete

and an explanation how to read it assembled in [HOWTO] Benchmark App Startup … in short: TotalTime is the time-to-fully-drawn that at best allows for user interaction, but this is not always the case, depends on the App.

1 Like

Almost all apps I think take time to open and sometimes going in parameters or doing some advanced tasks within an app have a delay.
The Fairphone 3 is not super fast but it is very fine for my taste but then since now I feel I did an update of iOS with an old iPhone.

I am just wondering if you use the search?
Because there are so many threads about this topic.
So, did you already checked the hints and tips there?
For instance here two of my settings for best performance:

The screenshots in my old post show the settings.
I am just writing this to make sure, it’s not an OS setting which cause the poor performance.

It is a little better and instead of opening Files in 4 seconds it is 3 seconds, some pass from 3 to 2 or 5 to 4. I think App Lounge and Waze are around 6-8.

Have you tried “Abgesicherter Modus”, I don’t know if its called “Secure Mode” in English?
When you long press the power button and get the power off and restart menu.
Long press the restart button. You get an message, confirm it and the phone reboot only with the preinstalled apps.
Now, check if it’s still slow. Because maybe some app is the issue.

Also I noticed, that when I reboot from “Abgesicherten Modus” to get back to the normal modus the screen stayed black and buttons didn’t work. So I had to long press the power button till the screen comes back on. Maybe this happen to you too.

I am on “Abgesicherter Modus” and it is slightly better, plus with “Animations off” and “Max performance” a little more too.
Unfortunetly, I still have a delay in many tasks and app starts.

It is kind of you to help me.

ScreenRecord-2022-06-03-01-24-57
I made a short video to give you a impression of the speed of my phone.
It feels quite responsive. But I don’t know if this is slow or fast.

For me the next step to determine an hardware issue would be to install another os, like the original fairphone android.
If it’s still slow with the original android, I am certain it’s an hardware issue.

But I am not sure. I know if fairphone android 9 is installed, one can not simple install /e/ os q (Android 10). First fairphone android 10 has to be installed then /e/ os. Why? I assume it’s an driver thing. So maybe something is not overwritten by /e/ os in some part of the storage.
So maybe it’s worth to start from scratch.
Or get in touch with the support.

By the way. Get /e/ os q v0.23. I stumbled about a camera bug in v1.0 and had to reboot my phone a lot get the camera working. Also reboot is not working. It’s not serious, but annoying.

Oh, just got an idea, to make it simple.
If you not updated your phone. Maybe it’s possible to switch storage.
Fairphone 3 is an A/B device. It has two storage.
So every OS upgrade is installed on the other storage. If something went wrong a fallback is possible.
First you had fairphone os installed via your warranty issue.
Then you installed /e/ os.
If the installation of /e/ os took the other storage, the fairphone os should be in the storage.
It’s just a guess.
I just tried to switch back to v0.23. But I got a message, that the partition is corrupt. Or something. I had the option to retry or do a factory reset. I guess a factory reset would do the switch, but all personal data is lost.
And retry got me to the same screen. So I hold volumen down and pushed retry, to get into fastboot. Then switched slots again and I am back to my current installation.
Here are the commands: (I am no pro, you’re doing this on your own risk. I can not help you if something went wrong.)
adb devices
Check if your device is shown. On the device switch to filetransfer and then authorize you pc if necessary. Debug mode had to be activated in developers menu as well.
́adb reboot bootloader
To get into fastboot mode, to see witch slot is active and change it.
fastboot getvar all
A long list appears. Look for “(bootloader) current-slot:b”
In my case it’s “b”. So I swtich to a now.
fastboot --set-active=a
Swtich is done.
fastboot reboot
Now the screen I described above should come. If retry won’t work, maybe try factory reset. But all personal data is lost. Or switch back like I did.

Or you install fairphone android. I guess there is an how to somewhere.

Yeah, a lot of work. Contact /e/ warranty support is surely the saver option.

2 Likes

Or just reboot or start the phone with Vol - pressed to get into Fastboot Mode, then do fastboot devices to check.
(At least on Windows different drivers handle ADB and Fastboot, so while adb devices could succeed there’s a possibility fastboot devices would not, in which case the driver situation would need to get sorted.)

fastboot getvar current-slot … avoids the long list :wink: .

Hey, I took some delay to answer because I am not so qualified to understand all this about phones, when I press the - button then enter Fastboot then go to recovery I have /e/ logo and says “active slot: a”.
Now I managed to record my screen:
ScreenRecord-2022-06-15-14-39-09
So it looks similar to you Inubu then I don’t know what to say, /e/ Android 9 was faster.
Anyway now I have other issues since the update: Applounge crashes, Telegram/Jitsi calls shutting down my phone, a very long press on the power button to turn it back on and no more camera.

I just resetted my fp3+. And “App Lounge” also crashes. :smiley:
So I went to “App Info” for “App Lounge” and under “Storage & cache” I clicked “Clear storage”.
After that it started.

Actually I just started my phone to see how /e/ OS in this reset state is performing. And it’s almost the same. Really not much faster. My Fairphone 2 feels faster to be honest. But it runs /e/ R (Android 11) and not Q (Android 10).
Now I try Fairphone Android, which is 11. And maybe I install /e/ R after that.
I’m curious if this is an Q problem.

PS. Have a FP4 with Calyx OS now as main phone. So I can test with the FP3+. Performance difference between this two Devices is extrem.

The difference between a 4 and 3+ or with Calyx OS ?
I guess that’s the game but I wanted to believe my smartphone could be as durable as my computers. I am gonna get a cheap smartphone then, maybe even used.
Let us know how it goes with your experiments.

I mean the speed of the hardware.

But back to my test. Fairphone Android is running great and /e/ R is also running great on FP3. Both Android 11.
It’s a pity that /e/ R is still dev. And there is still no way to switch to a new /e/ version, without losing data. But they working on that.

I think to run the FP3 most reliable one has to use the Fairphone Android. /e/ os is simple not mature enough yet, to install the latest updates instantly.

But for your case. I would just wait for the next release. Your phone is still working. And the release cycle is quite short, with one month.

And for the future. I would not install a new /e/ release immediately. I would just stick with the nice working version. And read here in the community forum how the newer versions doing, when I want to upgrade.
So like, now I got a bad v1.0. I would install v1.1 straightaway. But if v1.1 is running great, I would not upgrade to v1.2 without knowing how it is running. I learned the rules.
For the past, if I had learned this earlier. By now I would still be on v0.21 or v0.22.
Because here I would read a lot of trouble post with v0.23 and v1.0 for the FP3.

So just don’t install every new release is the key.
It seems like /e/ pushes out new releases like a factory. They only held back the release if the build failed or some major issues occur. Like build successful, installation successful, phone starts, nice, let release it. No testing and debugging for month possible, like other companies like Fairphone do. 4 Weeks seems to be the top rule. So this is clearly no way to serve costumers. And this is not the way to release a good product. This is the way to achieve fast progress in development. If users install the latest release, they are just a tester for bugs and issues.
That’s what is needed to know.
And I guess if /e/ has stable grounds for their android products, this may change.
As I have a spare FP3+ now, I probably install v1.1 and see how it is going.

And for me I still go the tester path. Calyx OS for FP4 is still in testing. Camera and Fingerprint reader is not working as it should be. And maybe the next release have some other issues. But it’s my mainphone now. :slight_smile:

You are right, I was happy with /e/ Android 9 and it is not worth for me having Advanced Privacy like this. I have /e/ since they started selling phones, sometimes I have some bugs but like every hardware/software and it is fine because I feel more having disrupting Deeptech pocket-computer than some bling-bling pitched experience. Well, Gael knows better because this launch has the right timing in my opinion, I can give it to the team. Now Murena.com is here they have a fine line to manage between tech entusiasts, pro-privacy and regular users like me.

Although, I could more easily forget with a new surprise. ( please please a communication app audio/video/messenging/file sharing )