[FEATURE PROPOSAL] Building GSI Image

Sorry for double post but I just noticed that dakkar’s build script already support /e/ (v0.2)

This means that you can build your own GSI image with just a few commands and fully customize it: with or without SU, A or A / B, ARM or ARM64 or A64… You can also add gapps :joy:

Only problem (if it is one): you MUST HAVE a pc under Ubuntu or Debian.

Check this wiki for more infos (also read the start ing of the page) :

Romname for /e/ is e-0.2
UPDATE : I’ve updated the script : new romnames are now e-pie or e-oreo, and e-0.2 is removed cause it’s an old version.

I’ll try to build some images (at least one for Aonly and one for A/B partition schemes) tomorrow.

1 Like

it’s pointing to a rather old branch (“v-0.2”) in the /e/ repository

Thanks please try and let us know. As mentioned some of our team members did not have much luck trying it. The correct branch names are
v1-pie , v1-oreo or v1-nougat

Cannot create GSI for Nougat cause Nougat does not support treble cause introduced in Oreo.
I’ve updated the script with new branches, waiting for owner to merge changes.

EDIT: Merged !

1 Like

Hi @AerisOne let us know how your efforts on building the GSI go ahead. We have unfortunately not been successful as yet.

Build in progress.
For the moment no problems.
EDIT : Issue when applying patches. Trying to resolve it.
EDIT : Seems issue is solved, I’ve said “seems” !

I’m building 4 images :

  • ARM A
  • ARM64 A
  • ARM64 A/B
  • A64 A
3 Likes

Thanks for taking the time to build the GSI’s.

1 Like

Hello, i’m trying to build the GSI too, indeed patch issues! The patches are not 100% /e/ source compatible. I’m stuck at 92% now, some function double defined in two .o files, don’t know how to fix yet. I also got trouble with libexfat_mkfs/fsck, did you have it too?

2 Likes

If we get this working, we could create an /e/ patch set!

2 Likes

You have followed the indications of dakkar say in the wiki that @AerisOne share? I would like to try to build a GSI too. I will install on my dipper, is trebeled too.

1 Like

I follow the manual instructions, so applying patches by hand.

Oks, thanks, I will try this weekend.

Edited phh’s script, dakkar’s script or even manual way are not working for me. Even when I try to build lineage or aosp, seem my computer don’t want to build any GSI sucessfuly.

I’ve edited phh’s script to replace lineage repo with e repo but it’s not working.

Same experiences like all others which.have tried :woozy_face::thinking::thinking::thinking:

Strange cause that’s not working even when trying to build lineage or aosp…

The build did complete 100% after some code tweaking, but it did not boot.

1 Like

So… You build it successfully but you can’t use the image, am I right ?

Can you tell me how did you do ? Or send me your image ?

On what phone are you testing ? Do you think this can work on a OEM-Treble-Enabled phone ? Can I have a try ? (Too many questions)

Thanks for confirming the errors we also ran into. The GSI scripts as they are on the Github do not work…at lest not for building the /e/ GSI.

I did the patches by hand, and where they’ve failed i tweaked the code by hand by looking into the patch and compare with the code to be patched. I commented out all the Xiaomi problems because i was going to test on Sony XA2 just to see if it worked. So sharing would not make sense, because it wont work.

If you’re using Phh’s patches, please check the releases page on GitHub, latest version is broken and won’t boot on any devices except Samsung’s. So you need to use an older version, and if you used a git clone command you’ve downloaded the broken release.