Feedback for v1.3

An OTA stable update version 1.3.1 will be released for the following devices

  • FP3
  • FP4
  • GS290
  • Teracube 2021 emerald
  • Samsung S9 starlte
  • Samsung S7 herolte
  • OnePlus Nord avicii
    The reason for the release was a regression detected in the widgets on the Bliss Launcher. The issue is marked confidential by the creator, hence not linked here.
    The release is being staggered on the devices.
    The build will also be available for manual download
5 Likes

???



Is there a question or an explanation coming up of what to do with those screenshots, or does the forum need a puzzle/riddle topic :wink: ?

Hello,
in browser, developer options, what functions?
Merci

@Cabnedor

Tracing is for analyzing performance metrics and debugging.
It is not a tracking or phone home feature.

1 Like

On /e/’s reconditioned Samsung S9, I upgraded to system 1.3-2 a few days ago (I do not know where to find the exact time). I suppose I was on latest 1.2 just before.
Around/since that same time:

  • hundreds of photos / pictures that were stored on the device disappeared. Hopefully, they were still available on eCloud
  • new photos / pictures / videos taken after the upgrade are stored on the device but still not synced with eCloud account after 7 days. Restarting phone, asking for sync, emptying cache of apps did not change. Calendar and notes are synced normally.

Strangely, the split happened in the middle of a photo session while too far from wifi & with mobile data off: first pictures shot during that session disappeared from the phone and were on eCloud, latest were on the device but still not on eCloud.

I am not sure if this is linked to images take long to upload to the /e/ server, even when the /a/ account setting say the device is synced (#1656) · Issues · e / Backlog · GitLab
I need to use email to transfer pictures on my Mac.

Besides this, all seems OK, although I still have difficulties having Maps’s GPS voice instructions operate when I want, since version 1.0. I still feel I need to dig deeper in advance privacy settings, so, I am not sure it is an issue at this stage.

FairPhone 4, no update to v1.3 yet.

1 Like

Im on Xiaomi Poco 3x Pro, does anyone noticed the battery drain is worse/slightly worse than v1.2 ?

I’m mainly only use Fennec Browser, Telegram and Whatsapp. No games on my phone.

What exactly does it say for you in Settings - About phone - Android version (tap on it) - /e/OS version (can be long-tapped and copied to clipboard since Android 10)?

If you are on the stable release channel, it seems you are running the latest stable release available OTA currently.

2 Likes

1.2-r-20220726206059-stable-FP4

Thanks for the clarification, I’ll wait :+1:

Weird, since I’m on the same phone and also within the stable channel, and I got my update

1.3-r-20220905216075-stable-FP4

Updated US model Samsung S9+ to v1.3. Since then connection to Gmail has been sporadic. Sometimes it connects and at other times I find an error message. I had a similar problem after updating to v1.2 only it was not sporadic.

The previous cure with v1.2 was to delete the gmail mail account and re-add it. I tried that now and cannot connect to Gmail at all. So I made things worse.

  1. I would like to get Gmail working again.
  2. I don’t want to be doing this every month.

I’m still trying to understand people on /e/os but who still uses gmail… Really trying. :thinking:

Stopping gmail seems to me to be the best solution

:wink:

More seriously, the best way for this kind of problem is to open a post on the github.

7 Likes

Me too:
1.3-r-20220823212872-stable-FP4

I have a Fairphone 4 and have upgraded from 1.2 to 1.3. Thanks for providing frequent updates for this os. I have thoroughly enjoyed since getting my FP4 a few months back. I have already had three flawless over the air os updates!

This time I have a small issue (so far) as I am having a minor issue with wifi.

I have a wifi symbol showing no connection to wifi both at the top right of the screen beside the battery percentage and also in the pull down menu. It also gives a written error message that it has connected to wifi but there is no internet. The funny thing is that wifi works fine and I am writing this from the same phone showing me that “no internet” message and the empty wifi icon with an x on it.

So the wifi seems to work normally except ithe icons and pop up messages show occasionally asking if I want to try another wifi network since the system thinks this and my other network dont work.

Interesting: I’ve seen something similar this evening.

My oneplus 3 running 1.3-r has been very stable until this evening when I brought it back to my home WiFi zone. Earlier, this evening WiFi status in settings was “connected, no internet” and I could not fix that after looking at various posts & solutions here: reboots, developer options, etc. Turned off mobile data while testing.

Set the phone aside for a while. …

Came back to the phone just now. It still shows WiFi icon with an x at the right of the status bar. In WiFi settings, status is now connected though.

Mobile data is still off. I’m reading this thread and responding using my phone, over WiFi, despite the status bar icon showing I have no internet via WiFi or mobile data.

Oneplus 3 running 1.3-r-20220825212931-dev-oneplus3

1 Like

The Teracube 2e stable update is held up due to this issue
The device stable build is still on v1.1
While the team is working on resolving the issue, we do not have an ETA to share.

3 Likes

This is possible theoretically.
“x” or not “x” is dependent on a connectivity check trying to reach certain addresses in the internet for a short answer. If these addresses are somehow unavailable or if this check might fail in a different way, the rest of the internet could work fine on the phone while the “x” would be displayed due to the failed connectivity check.

The connectivity check and how /e/OS wants to handle it is mentioned in this white paper.

Also see https://gitlab.e.foundation/e/backlog/-/issues/268#note_18097, mentioned in the white paper.

If this is not just a temporary phenomenon for you, it would need investigation. Could be a firewall App on the phone or your Wi-Fi router firewall is blocking the connectivity check addresses, could be there’s indeed an issue on your phone, in which case you could open a GitLab issue to get in touch with the /e/OS developers about this … Issues · e / Backlog · GitLab.

4 Likes

Samsung S7 :

  • All pictures disapeared from “OpenCamera” but hoppefully they are still on my murena account.
  • People I call still complain about earing their voice in echo : this issue
  • I am using my bluetooth headset to avoid the echo, but the sound is very noisy during calls. No sound problem with other uses.
2 Likes

Poco X3 Pro user here. The CTS Profile still does not match as part of the Safetynet test. I’d really love to see that fixed so I can properly report on what banking and shopping apps work without the need for Magisk and its modules.