FP3 after installation /e: wlan always off, MAC 2:00:00, phone number not identified, no ringtones, no lamp

I tried to install /e with the easy installer, it didn’t worked so I used the command line, it worked with boot_a (as I read this could be a bug in fastboot), I died not locked the bootloader. https://images.ecloud.global/dev/FP3/IMG-e-0.10-p-2020080666687-dev-FP3.zip
Now I tried to setup wlan connection, but it looks like it is impossible, MAC address is 2:00:00…, the phone number of sim card wasn’t correctly identified, I can’t hear any ringtones, lamp function is not available. So I’m concerned I missed some important information. Could somebody help me please, finding the light? resetting wlan, bluetooth didn’t solve this problem (empty screen)
I flashed it 2 times, I checked md5.
wlan, ringtones, phone calls, lamp were perfectly working on FP3 OS
Thank you in advance.

Hello, welcome to the forum.
I think it’s better to install the stock fairphone OS first, and check if everything works. Go here and follow the instructions.

1 Like

If it works, run this script to install /e/, assuming you use linux.


it worked, perfectly, now _b was flashed. :smile:
Do I need to run the script again or just in case of trouble after the first try? I saw while flashing stock fairphone OS _a and _b were flashed.
My serial number is No_Custer_Serial_Number, is this normal or an issue?
Thanks a lot for your time and energy.

Welcome, if it works you don’t have to re-flash. Have fun with /e/!

Don’t know about the serial number, where did you find this serial number?

The number is the device name which I saw after e.g. fastboot devices
or in about phone -> model and hardware (below SIM status 2)
This serial number is needed to get the oem unlock code from fairphone. https://support.fairphone.com/hc/en-us/articles/360041655711
In my case it is done, after reinstalling stock fairphone OS the oem was still unlocked. My phone is already unlocked (bootloader), so I’m not sure what will happen if I try to lock the bootloader (security issue?) I’m quite new regarding topics like this.

in model and hardware is written

Could somebody with a FP3 and /e/ please check, if there is a correct serial number? Thank you in advance.

My number is not identyfied, telephone number 0176000000000 (sim1), phone calls are fine, displayed number from where I called is correct.

Could somebody with a FP3 and /e/ please check, if there is a correct serial number?
in about phone -> model and hardware
Thank you in advance.

On my phone yes, there is a correct serial number. Sounds like an issue.

Works correctly for me, too.

Thank you for checking.
Bad luck I didn’t copied this number before flashing, I couldn’t imagine, that a serial could be broken, erased or manipulated anywhere.

I check sim2, no correct identification of phone number, but MAC was 2:00:00…again
After connecting with wlan, a correct number appeared.

On fastboot mode the internal storage size is unknown, used memory in /e/ is correct.

I started a ticket at fairphone, but automatic answer, I could push and reply. This phone is 2 weeks old.

Any suggestions?
Thanks for supporting me.

in your previous experiments you seem to have problems with the EFS partition that holds the MAC and other device identifiers. I was never affected by such - this guide suggests (multiple methods to) erase the partition in question. Why the Android should recover from the erased partition - I have no idea, it’s not noted in that guide. I think it presumes you have working backups of that partition - that you don’t have. Check with the fairphone forums, either search for 02:00:00 or EFS partition. The device details should be able to be read out of the firmwares at first boot (IMEI at least - MAC can be randomized anyway)

Thanks for this guide. I’m not sure what will happen, I don’t want to risk to destroy more…
Fairphone support- I hoped to get more information
Is there a opportunity to check defects in filesystem, a safe way to read out EFS etc.?
By flashing stock fairphone OS, I observed both a and b were flashed boot, vendor… I’m not sure what is still remaining, ok on b /e/ OS.
I did not find some blogs about EFS on fairphone forums.
To be honest I think there are tools but that could be easy beyond my level.
Is there anything I could do? Thank you for helping me with that topic.

btw, in “About Phone” - your phone numbers aren’t noted per SIM slot automatically - only the IMEI per slot. If only Wifi is your problem, setting any random MAC could help. But yes, there’s a serialnumber per Phone, but apart from RMAs to the manufacturer it doesn’t matter.

in https://forum.xda-developers.com/android/general/info-android-device-partitions-basic-t3586565 it is written

If MODEMST1 or MODEMST2 are erased (by wrong factory flashing say) and phone notices an invalid partition, FSG and BACKUP will be restored.

you can use dd or TWRP to take backups first of both modemst partitions, than zero’ing with dd or fastboot. If the boot process detects the empty partitions, it supposedly repopulates them again (they’re small at 1.6MB each). Worst case you’re back to square one.

Wifi is not an issue, :slight_smile:
Serial: That sounds good, I was afraid the serial could have an influence to upgrading to Android 10 eg… Last Time as I went back to stock OS it tried to do some preparation for my backround (after restart, inside stock OS), I never had an account (google…), but never finished. I’ll try to backup EFS, just to make sure for future.
Thank you for helping me.

I had the same issue as the OP, my serial number was reset to the nonsensical “No_Custer_Serial_Number” after a fastboot flash operation, see screenshot:

I “fixed” it by overwriting the bytes at offset 0x30 of the prodinfo partition with my old serial number, no bad effects so far. :slight_smile:

1 Like

Congratulation! :slight_smile: I didn’t have my original serial anywhere, embarrassing. Do you know at which point it happend? Reinstalling fairphone OS Android 9 or “just” flashboot flash operation? Which platform did you use for overwriting?

I suppose the serial number might be found printed inside the casing. Also check any TWRP backups you might have - they are stored in a folder named after the serial number (mine started with ‘A’).

The error with the serial number occured during a fastboot flash. During the flashing, I pressed Volume Up, and then, for whatever reason, the serial number displayed in the fastboot menu disappeared and was replaced with that nonsense string.

I used an adb shell to dump a partition image of prodinfo with dd, you will find plenty of guides on the details. Then a hexeditor of your choice to overwrite the relevant bytes, and another dd (or perhaps fastboot flash directly) to overwrite the partition with the modified values.

Note: this is dangerous stuff and I give no guarantees for success.