FP3 latest update corrupt, doesnt work

@piero: While I applaud your enthusiasm in wanting to help others … Could you please check whether what you are advising actually works for the Fairphone 3 before posting about it?

Not every Android phone works the same way, not every /e/ phone has TWRP or uses it to install /e/, and booting TWRP with fastboot is not the same procedure on every Android phone - some phones (Fairphone 2 for example) need signed images not available at twrp.me for this, some don’t.
Please be more careful before you get somebody’s device bricked :wink: .


I have no FP3 to test these links :



The Fairphone 3 is an A/B device. It has two slots for the OS (A and B). While you use one slot, updates get installed to the other slot in the background.

If you are familiar with the fastboot command …

fastboot getvar current-slot … should give you the slot which now doesn’t boot … or “INVALID” if something went even more wrong.

fastboot --set-active=a or fastboot --set-active=b … will set the slot for the next boot. Try whether the phone boots with this. The data partition is shared between the two slots, so the data will be the same and hopefully not affected so far.


Quite a number of users here have a Fairphone 3, so perhaps you should let us handle the Fairphone 3 stuff :wink: .

Yes, TWRP is available for the Fairphone 3, I use it myself.
But on the Fairphone 3 you usually don’t install it, because installing it results in a changed boot partition, as there’s no recovery partition on A/B devices.
A changed boot partition breaks OTA updates when using Fairphone OS, and in case of using /e/ it will just get overwritten by /e/ updates with the LineageOS recovery (or future /e/ recovery) … so there’s not much sense in installing TWRP on the Fairphone 3, so the Fairphone 3 usually doesn’t have it in recovery mode.

Booting TWRP with fastboot works, but like I said, please be more careful with assuming everything would work with every phone.


Thanks a lot @AnotherElk! It works now!

How should I update my system now without getting this error again?

1 Like

I didn’t install it myself yet, but apparently it has worked for other users … FP3 Sept update.
Try again if you dare :slight_smile: … you know how to get back to the formerly working slot now.

Can I install it by my own without loosing data? (on the same slot which i use normally)

Using these commands:

 fastboot flash system system.img
 fastboot flash boot boot.img
 fastboot flash vendor vendor.img
 fastboot flash dtbo dtbo.img
 fastboot flash product product.img
 fastboot flash vbmeta vbmeta.img
1 Like

Why not install it on the slot you don’t use currently? So the currently working slot stays in a working shape?
Data should not be affected as long as you only flash the partitions an initial install or update flashes and you don’t wipe userdata.

If you don’t want to run a risk of messing up the slots, you can append every partition name (apart from userdata, of course, but you don’t flash that anyway) with “_a” or “_b” when flashing them.
E.g. fastboot flash system_a system.img or fastboot flash system_b system.img would force flashing the system image to slot A or B, respectively.


@AnotherElk thanks! You helped me a lot.

This update crashed my phone as well. Will try to boot other system. Would be nice if that was an option in the GUI instead of just “factory reset”.

Here’s the kicker, I guess this is with the expectation that you are using the adb device that you initially installed /e/ with, because whenever I invoke anything to do with adb:

adb devices
[DEVICE] unauthorized

and with fastboot:

fastboot getvar current-slot
< waiting for any device >

I’ve rebooted my machine and ran as root, but the problem persists.
I suspect this is because I’m running this on another machine (I don’t have access to the other), and I haven’t clicked the “authorize device” thing when connecting to android with adb on this one.
The computer I flashed /e/ with had arch, and the one I have now has manjaro. Thankfully, I have full access to the /home/user backup of the other machine, so if there are any keys I can use in order to authorize myself in some config directory, I can do that.

Is there a way to do this on a computer that hasn’t been authorized yet? If not, can I load a key from a computer that was authorized to my current one in order to get authorized? If not, is my only option to factory reset?


This has nothing to do with ADB and the authorisation for ADB.

That’s fantastic! Thank you so much!
Now, how do I go about getting my other slot (in my case, b) into working order? I wouldn’t want to end up in the same situation, but this time with both broken slots.
Can I just flash a known good image onto my other slot with the instructions from

but this time without the

fastboot -w # Wipe user data


You are using a working slot now. A new update would update the other slot in the background again. You would still have the working slot. I don’t see a problem.

But if you are feeling adventurous :slight_smile:

By the way … Do you have a backup of all your important stuff?

Turns out I am feeling quite adventurous and I think this will serve as useful knowledge down the line.
And yes, I will get onto backing up everything I can :rofl:
Thanks again!

1 Like

how do I get there? Is it over the factory data reset? Or is it the thing were I have to push the power button very for long

Press and hold power+vol down, yes the screen with start etc.

1 Like

If I press and hold the power button and then chose “start” it says: “can’t load android system. You continue to get this message, factory data reset and erase a device”

this basically means I can forget all my data, doesn’t it?

I did not even get to chose between slot A and B

You must type these commands on your computer.