FP3 (Magisk-rooted) F-Droid Privileged Extension Issue

I can’t get the F-Droid Privileged Extension to work.
I don’t exactly remember, how I did it on my Galaxy S5 (LineageOS for microG)…

On the FP3 (Magisk-rooted) I tried downloading the /data/data/org.froid.fdroid/ota/…-thing via F-Droid, booting to TWRP, installing the downloaded file, rebooting and then installing the Priviledged Extension APK.
When I go to F-Droid’s expert settings, Privileged Extension is activated.
When I want to install an available update, I get “Error installing … - The privileged permissions have not been granted to the extension!”

Did I miss something?

I think you have to install root for this.

Personal note: I don’t like rooting a . It makes it unsecure. So I always prefer to think twice before installing root. Especially when there are easy workarounds. In your case: You can install all easy with one push manually

Hi, sorry, I edited my post. The FP3 is rooted (with Magisk)!

Have you checked in magisk manager if the app is registered for root access?

It isn’t, but it also doesn’t ask for root…

That’s the issue I think.

I think so, too. But how can I fix it?

Sorry, don’t know. As I have written, I don’t like root and I think everyone will be able the update manually. Sorry, it’s my absolute personal meaning :wink:

You mentioned you installed the Privileged Extension apk after rebooting. No need to do that. When flashed ithe extension will be in /system/priv-app/ and should just work.
Only reason to install the apk normally (root required) is if one were unable to flash it.

The ota zip seems to be in order. Includes necessary permissions file, supports system-as-root, etc. The flashing should’ve been good to go.

1 Like

Yeah, I thought so. Just tried the APK, because it didn’t work. What else can I try?

Hmm, I wonder. Check to make sure the permissions file is present.
Within the ROM it should be…
/system/etc/permissions/org.fdroid.fdroid.privileged.xml

Or in TWRP, on A/B devices…
/system/system/etc/permissions/org.fdroid.fdroid.privileged.xml

With the following contents…

<?xml version="1.0" encoding="utf-8"?>
<permissions>
    <privapp-permissions package="org.fdroid.fdroid.privileged">
        <permission name="android.permission.DELETE_PACKAGES" />
        <permission name="android.permission.INSTALL_PACKAGES" />
    </privapp-permissions>
</permissions>

I figure if it is not there you can create it(?). If all else fails maybe start fresh. Uninstall F-Droid then get and install NanoDroid-fdroid package. That’s what I use. Root not required also.

Thanks marcdw, I guess my mistake was that I always mounted system as read-only in TWRP following some FP3-specific advice. I’ll check what the cost of mounting it rw is. That should solve the F-Droid Privileged issue, right?

Unfortunately I observe another problem with my /e/: I can’t get push notifications to work, because no app tries to register with microG. Threema and Telegram have own push solutions that work, but Signal’s doesn’t, even when it (as it seldomly does) shows the “background service blabla” notfication. Signal I use the most, so I need to solve this.

NanoDroid looks very promising and I’d just install it completely, but at first I’d like to understand what exactly my problem is and if I can fix my /e/ without installing something over it.

No, I wouldn’t install NanoDroid over /e/. That might prove problematic. There are standalone, smaller NanoDroid packages. There’s one with only F-Droid/AuroraDroid.
Check the downloads here.

I don’t use Signal but there has been much discussion in these forums. Just do a search.

Normally in TWRP there’s no reason to make /system rw unless you’re doing some manual copying, editing, or file management. When flashing items, the scripts in the zips handle the mounting with rw and all that. Normally.

1 Like

@lkesjbnrti, I was in the F-Droid forums looking for something unrelated and came across a thread with an issue similar to yours. Some good tips from the experts there.

F-Droid PRIVILEGE EXTENSION ZIP NOT WORKING
and
Should F-Droid client and Privileged Extension OTA be flashed at the same time?

Maybe more of an issue than I thought. At least on Q.

Thank you very much!
Yes, I found several posts about the Signal issue. It should be solved with the next version and a reinstall or only reregestration. But that only solves the fallback push service for Signal.
Still, F-Droid Privileged and the push service of my microG installation are messed up. Thanks again for your links, I’ll check them now!

With the Signal fallback push service working I will wait for the next updates, maybe those repair my microG and F-Droid Privileged. If not, I’ll install NanoDroid F-Droid and microG over /e/ and if even that doesn’t help I guess I have to reinstall. Still no idea what went wrong initially…