FP3 problems - Audio and Camera app not working... "FAILED TO OPEN CAMERA. CAMERA MAY BE IN USE..."

I have a Fairphone 3 running /e/ on it, I’m running the most up to date /e/OS 0.20 on Android 10.
I have a number of issues that started a few weeks ago (these issues continued on /e/ 0.17, 0.18, 0.19, 0.20 - I tried all of these different versions to be sure it wasn’t that I just needed an update or to revert). I have also cleared data and restarted the phone many times, nothing has fixed it. Please help!
Problems:

  • Camera app doesn’t work, opens and reads “Failed to open camera. Camera may be in use by another application? ID:0” I can open the camera settings and look at photos but the camera simply won’t work.
  • Also, the flashlight tool does not work. Where the flashlight button is in the drag down tool menu, it just looks greyed out and you can’t click on it or if you touch it nothing happens.
  • Calling… when I call or someone calls me (any calling, on apps or regular calling) I can hear the person but they cannot hear me, then when I switch to speaker phone, suddenly they can hear me but I can’t hear the other person. I can use headphones to get around this issue but headphones are now not always reliable.
  • Audio… I cannot listen to anything through the FP3 speaker, music or podcasts or an audio message - it is totally silent. On the screen it appears as though it is playing it aloud and I can click up and down on the volume but it remains totally silent.

To summarize - I never dropped my phone or put it in water, there is no damage to it. I use it regularly and update it. Nothing seems to fix these apparent software glitches. Any advice is helpful thanks !

Welcome to the Murena community :slight_smile:

It sounds like there is a problem with three modules: camera, speaker and bottom module.I would recommend you install the app “Fairphone Checkup” to test your primary microphone and your rear speaker. This could help confirming if it’s a hardware or a software issue.

If the test confirm hardware issues, I would recommend you open your FP3 and make sure the three modules are screwed in right and the contacts are still clicked into place. Instructions can be found here:

1 Like

Thank you for your quick and helpful reply.
I downloaded the Fairphone Checkup, I tested Ear speaker, Rear speaker, Primary mic, Secondary mic - all failed.
Does this mean it is a hardware issue?

Well, what you wrote in your first post is not consistent with the failure of the ear speaker and the secondary microphone (the tiny hole at the top slim side, not far from the ear speaker on the display’s top end). From what you wrote there, these two should work.

The thing is Fairphone Checkup was originally designed for the Fairphone 2, but so far it has worked fine for me on my Fairphone 3+ as well. FP3 and FP3+ come with a significantly larger range of built-in hardware tests under Fairphone OS, but those are not available under /e/OS. In case you contact Fairphone Support, they might ask you to go revert your FP3 to Fairphone OS in order to be able to conduct those tests and make sure it’s not about /e/OS,

I guess you don’t want to do that right away, so in your position I would try the dis- and reassembly as described in the link. Especially the camera issue might be fixable this way as what you described very much sounded like the phone simply cannot connect to the (main = rear) camera module (the “torch”/flashlight is included in this module as well). One tip that can save you a bit of hassle: From my experience, the display will work again after reassembling the phone even when the 13 screws holding it are not screwed back in – as long as you really make sure the plastic parts that hold together display and the rest of the phone are audibly clicked back into place. Of course, eventually you need to screw these 13 back into place as well, but as you will want to TEST if your attempts to fix have worked, you might save yourself a lot of back and forth with the many screws until you are finally done with testing everything.

1 Like

P.S.: You did download Fairphone Checkup from the preinstalled “Apps” app, right? Version 2.1.8.

Yes I did instill it from Apps (not Aurora) and it is version 2.1.8. I think the way the test is designed meant that they all failed since some tests relied on another feature. My rear and ear speaker did not work, both failed. When I use my phone normally the ear speaker never seems to work, the rear speaker does not work for any audio like music, podcasts, or listening to audio messages BUT it does work for speaker phone… very strange. The mic tests both require your speakers to work so you can hear yourself speak into the mic, so that test failed but it is unclear if it is the mic or the speaker that failed the mic test.

I also unscrewed the back following the instructions, I checked all of the modules. They are all connected properly and appeared to be connected properly when I opened it. I disconnected them and reconnected them to be sure, I can see they are locked into place. I put the screen and battery back and the phone continues to have all the same problems.

So I guess this confirms it is a software issue?

Thank you so much for your advice !

1 Like

Sounds likely, yes. I guess all these hardware failures together would be a very big co-incidence.
By the way, my FP3+ is on /e/OS 0.20 as well and I don’t experience any of these issues.

Maybe a factory reset would be worth a try in your case. I also seem to remember talk of a “Factory Mode” or “Safe Mode” on the Fairphone, but I cannot remember specifics and whether it was available for the FP3 as well, and if also under /e/OS …

1 Like

Alright, that is good to have confirmation that I should do a factory reset. It was pretty much my next big idea but I didn’t want to if not required.

I’ll try that and see if it improves anything. Thanks again

1 Like

After factory reset… nothing is fixed.

Now what? Do I dare go back to Android/Google and then get FP to help?

Sorry to hear. If you haven’t done so yet, here are the instructions:

Once Fairphone OS is installed, remember there is a more comprehensive set of hardware tests available. Just dial (using the phone app) the code * # * # 6 6 # * # *

P.S.: Not in good shape today. Hope others will help you.

1 Like

see if the option to disable the sensors is enabled

where would that option be? how could it be enabled after a factory reset?

I have searched very deeply to find Developer options and this sensors button but I cannot find it… sorry to bother you but can you describe how you got there?
thanks

Settings > About Phone
Hit “build number” like 10 times and you will get a message that you unlocked the developer settings
Settings > System > Developer options