Galaxy S9+ Installation with easy-Installer on WIN - no booting in TWRP

Dear Community,

Yes - I´ve read corresponding articles first (as a new user I may only post two links):
…and watched the video:

Still, I´m having issues with entering the TWRP. I tried to install eOS for about 15 times, with high concentration on pushing the correct buttons at the correct time. But nothing worked. Now I´m not sure, if I am really too clumsy or if there is maybe a technical issue. Or do I miss the big red button which says “push me and everything is fine”?
Could someone please check on the LogFile?
Log file: hastebin

Phone: SM_G965F
WIN 10
Easy Installer version: v.0.15.0

Here my Workflow so far:

  1. Download and installtion of EasyInstaller: OK
  2. Connecting phone to PC with cable: OK (I tried 2 different cables, both of high quality)
  3. Starting Easy Installer and following instructions:
    3-1) Prepare: OK
    3-2) Connect Phone: OK
    3-3) Developer Options: OK
    3-4) USB Debugging activated: OK
    3-5) Default USB configuration set to file transfer: OK
    3-6) Deleting accounts: Not neccessary - no accounts installed (refurbished phone): OK
    3-7) Driver check: WIN 10 downloaded the drivers already: OK
    3-8) Easy installer tells me, that my device is compatible: OK
    3-9) Automatic download of files: OK
    3-10) WLAN is connected: OK
    3-11) Auto system update is deactivated: OK
    3-12) Auto software update is deactivated: OK
    3-13) Auto software download via WLAN is deactivated: OK
    3-14) Clicking on “download and install” and wait for response: OK
    3-15) Device reboot: OK
    3-16) OEM unlock: OK
    3-17) Boot to download mode: OK
    3-18) “Continue” with pressing VOLUME UP: OK
    3-19) Waiting for Easy installer to install recovery program: OK
    3-20) Then I try to reboot to e/OS recovery mode, but I´ll always enter the “standard” recovery mode from android.

What kind of (user) errors should I double check? Cables, locks, specific phone model, motherboard usb-drivers…?

Thanky you for any help and hint =)

Hi @Lonad_West welcome to the /e/ forum.

I read your log briefly; I saw 72 matches for
ERROR: Failed to detect compatible download-mode device.

You have researched well and I think we must be looking for something unusual.

Please can you check if the device is in KG or RMM Prenormal.

If this is the case it will appear on the Odin mode aka Download mode screen.

If yes to above, please read on to Region lock; Prenornal may well lift if the phone is in fact used with wifi and a SIM card for a while.

Hi @aibd,

thanks for your fast reply! I do have an interessting state of “KG STATE” in Download Mode:

CURRENT BINARY: Samsung Official
KG STATE: Checking
Secure Download: Enabled

The KG State sounds like is in a state it shouldn´t be in.
(Additionally, I have to correct statement of device status: It is refurbished, not new. I´ll change this in the first post as well.)

Thanks so far! =)

Well checking is considered ok usually.

a) it is possible this has changed since your first run of Easy installer, so you simply might try Easy Installer again.

b) Is the original Samsung still functional?

If yes, without introducing a Google account, can you introduce wifi and / or a SIM card?

It might be an advantage to get the device online for a spell, then try Easy Installer again.

I generally flash a device with a SIM card present and if possible tested.

Edit to add a cross reference Samsung Galaxy S9 "only official released binaries are allowed to be flashed(RECOVERY)" - #55 by ronnz98

Dear @aibd ,

It just worked and I managed to install e/OS on my phone =) Thanks a lot!!!

For all the other desperate people looking for some help, I´ll share what I have done:

  1. Inserted SIM card (for about a few hours).
  2. Activated Location (GPS) Service.
  3. Made a 5 minute call.
  4. Reinstalled Easy-Installer.
  5. Used another USB cable.

At the end, it worked out! I do not exactly knwo which of the points was the crucial point. Probably it had to do with KG/RMM.
But be encouraged, that this great community provides quite accurate support. =)

Thank you @aibd =)


to @aibd, some Interresting things about RMM : Post in thread '[RECOVERY][OFFICIAL] TWRP for Galaxy S9 and S9+ (Exynos) ’

1 Like