Help needed: Installing /e/ on FP3+ caused "bootloader loop"

This post was flagged by the community and is temporarily hidden.

Can you provide the log file as described in Howto troubleshoot issues with the easy-installer

Thanks for your quick reply, Ingo! Sure, I found three files which I cannot not upload here since only images are allowed and just pasting the text of the log from the day of the installation here gives me an error (probably it´s too long?). How can I send it to you?

In some other topic https://paste.c-net.org/ was used to upload long logs

This post was flagged by the community and is temporarily hidden.

It’s strange, the log stops way too early with

2020-11-15 14:39:53,393 INFO [JavaFX Application Thread] e.e.i.EasyInstaller [null:-1] stage is closing

That’s after the installer wiped the user data and started the flashing of the first file in the archive.

Probably the fastest way to get the phone back up would be to execute in a command prompt (cmd, not powershell) when the phone is in fastboot mode:

cd C:\Users\CC-Student\AppData\Local\easy-installer\sources

"C:\Program Files\easy-installer\bin\adb\fastboot" flash system_a system.img -S 522239K
"C:\Program Files\easy-installer\bin\adb\fastboot" flash boot_a boot.img
"C:\Program Files\easy-installer\bin\adb\fastboot" flash vendor_a vendor.img -S 522239K
"C:\Program Files\easy-installer\bin\adb\fastboot" flash dtbo_a dtbo.img
"C:\Program Files\easy-installer\bin\adb\fastboot" flash vbmeta_a vbmeta.img

"C:\Program Files\easy-installer\bin\adb\fastboot" flash system_b system.img -S 522239K
"C:\Program Files\easy-installer\bin\adb\fastboot" flash boot_b boot.img
"C:\Program Files\easy-installer\bin\adb\fastboot" flash vendor_b vendor.img -S 522239K
"C:\Program Files\easy-installer\bin\adb\fastboot" flash dtbo_b dtbo.img
"C:\Program Files\easy-installer\bin\adb\fastboot" flash vbmeta_b vbmeta.img

"C:\Program Files\easy-installer\bin\adb\fastboot" flashing lock

Hum, sorry, no idea about what went wrong there, just tried to follow the instructions.

Ok, thanks for the hint. Apologies, never used cmd so probably I made some rookie mistake here:

image

If you can recommend any guide for that I´ll be happy to work through it instead of bothering you :wink:

You forgot the cd in front of AppData

What you entered was
AppData\Local\easy-installer\sources

but you need to enter
cd C:\Users\CC-Student\AppData\Local\easy-installer\sources

Ok, hehe, got it, and then I still have to enter all of this somehow?

This post was flagged by the community and is temporarily hidden.

Yes, each line individually. If one gives an error it doesn’t make sense to proceed with the later ones before resolving the problem.

1 Like

Ok, still sceptical, but it seems it worked, or at least the phone asks me to lock the bootloader now. But I should leave it unlocked, right? (That´s what I just read in another topic)

Well, Fairphones sold with /e/ preinstalled have a locked bootloader, so the installer will lock the bootloader as well. As that didn’t work for you and you had to run the commands manually, it’s up to you if you want to lock the bootloader or not. You can lock it later if you don’t do it now, but that will wipe the user data as far as I know.

Ok, thanks for the info and many thanks to all of you for yourl help and pacience. /e/ seems to be installed successfully. All the best!

2 Likes

Probably one last question: how did it fail? The log looks as if the installer simply closed, but what happened visibly on the computer? Any error message? And what happened on the phone at the same time?

The installer did not close. After entering the fastboot mode, the installation was in progress but then the installer suddenly said that /e/ could not be installed or something. It offered me to try again, but after a several attempts I decided to actually close the installer, hoping I could maybe start the whole process again, which of course did not work.

Hope that helps … Anyway, I tried to follow the instructions but it could be possible that I messed up the steps in fastboot mode on the phone as well.

Ah, thank you. That makes sense. Could you also upload the other two log files? I assume the one you already posted was the last one.

Sure, I sent you the second one actually. The third one was probably some additional desperate attempt hehe. Just tried to upload it but it´s even too big for paste.c-net. Any alternative?
Could upload log no. 1, but now this forum tells me I could not “post a link to this host” - well it is paste.c-net [dot] org [slash] SplitFuneral