Help with install on Galaxy 9+ SM-G965F/DS with RMM "Prenormal" Lock

Hello,

I’m looking for some help with installation. I was using the Easy Installer but after fiddling around and digging for hours on this, I realized that my phone is RMM locked due to a Samsung software update from the last couple years. I’m even trying to do this through Heimdall but the instructions I’m following from the docs aren’t working. I’m basically running into brick wall after brick wall. I bought the phone just for this purpose. I would’ve liked to get a different phone but there aren’t really any other stable versions and Fairphone isn’t available to me. And it was actually very difficult to find this phone as well due to it being rather outdated.

Is /e/ basically a dead project that’s minimally retained or maintained just for those who managed to install it? Because the most stable versions are all for Samsung phones and newer entrants like me can’t even get it installed due to Samsung’s locks. I mean, I really want this to work - that’s why I bought the phone. Is there a way around this? If not, is there a way to manually deGoogle?

Edit: Forgot to ask, are there any plans to migrate away from Samsung devices? They’re the worse when it comes to allowing users to customize their phones.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @starchy welcome. I have to ask the reason why your phone got RRM Prenormal?

Where are you using this phone? Where was it originally sold?

Hi @aibd thanks for the response. I bought it brand new and it arrived yesterday. I’m using the phone in Canada and its baseband version is G965FXXU7DTA3. So I guess I no longer have bit 1 or 2. The phone was built originally for the UAE as the box label says “SM-G965FZKDXSG” with the XSG part referring to UAE.

When I got it, I proceeded to get the “OEM Unlock” button to display in dev. In the course of doing so, I had no choice but to install one of the security upgrades from Samsung. It worked and the OEM Unlock button was revealed. Unfortunately, I think that one security upgrade also caused RMM to lock.

Any suggestions? I’ve been reading some other forum posts and it appears that people have been having this problem for a while. Is there any way to do this without a custom recovery? Can I flash /e/ OS from ADB or Fastboot?

I would say you are the innocent party in an international scam.

What are your options?

Samsung sold the phone at low price to UAE.

Someone exported it to Canada.

Canada does not want you to have one of these options devices.

Encore, what are your options?

RTS on account of the the device did not meet your reasonable expectations.

Bon chance.

Hello starchy,

Were you able to get this resolved? I too have imported this very phone to Canada, and it appears that it was originally built for UAE. I have not tried to install /e/ yet. I hope it is possible. I too purchased this phone for this very purpose. I am not intending to use the Easy Installer as that only gives you Android 8. I plan to update the phone to Android 10 and then install the beta /e/ version of Android 10.

the device must to be first activated with an European mobile operator SIM card
And must have been used for more than 5 minutes with that European mobile operator SIM card

I don’t know if it must used on an European GSM network or not. That could be a possible workaround for American users who could share with each-others an unique european SIM card with worldwide roaming option. Lol

If the phone is not a new one but used / secondhand : no problem

I wonder if flashing a combination firmware, then a firmware with CSC that matching your area could solve the problem, but it possible there are no compatible CSC for your area as they ship other models

Can I suggest you search some USA threads and the research by @egx470, the methods available to work around Regional lock are reported much less possible on Android 10.

Thanks for your reply @piero,
I bought this phone off of eBay and was under the impression that it was brand new, never used.
However, the seal was broken. I assumed that the seller had been charging the phone to extend the battery life. But, now I’m hoping that this phone has been activated once with a SIM card in its original region. I guess I won’t find out until I attempt the install. I plan to do this in November when I have some time off. (My old BlackBerry is not EOL until January. I was hoping to never have an iOS or Google phone). Hats off to the developers :slight_smile:

Better use Motorola or Oneplus in your region,
Check your carrier frequencies and compare to phone models capabilities

.

Hypothese :

If device is already running stock android 10, don’t do any update ! don’t connect it to the internets (WiFi nor data/SIM)
flash recovery
Install /e/

If device is actually running stock android 9, don’t do OTA update ! don’t connect it to the internets (Wifi nor data/SIM)
maybe flashing stock firmware 10 with Odin will works.
after flashing, reboot the device, BUT don’t setup android languages, time, network, etc…STOP IT,
reboot to download mode to flash recovery with Odin
then install /e/

RMM : PRENORMAL Samsung Galaxy S9 "only official released binaries are allowed to be flashed(RECOVERY)"

Search results for 'RMM @egx470 order:latest' - /e/ community

2 Likes

Thanks @piero,
I already updated to Android 10 from Android 8 yesterday over wi-fi. It looks like I’m SOL.
Also, the OEM Unlock toggle is missing in Settings > Developer options. My guess is that this device has never had a SIM card in it. I’ve recently learned that the device will reset when a SIM card is first inserted. Perhaps for some strange reason the toggle will magically appear when the reset forces the device back to Android 8. I’ll consider my options when that time comes. Thanks again :slight_smile:

Thanks. I’ll give it a try. Perhaps there is still hope.

Not yet, read all the articles first

1 Like