How to get plain tts voice in osmand on lineageos (16) without microg or tts included

In case someone else has voiceless osmand navigation.

Install flite tts app from f-droid and run.
Under manage voices, pick 1 and download.
Under tts demo, click test lines of text to play, for test.
In android system settings under accessibility, text-to-speech output, set preferred engine to flite, give permission when requested.
voilà

Also, if running orbot in VPN mode, you can set osmand to use it, because it does call home. (Offline maps preferred; online maps speed will be slowed in orbot)

1 Like