I am having tons of trouble trying to install /e/

I am trying to install on a Google Pixel (Sailfish) and I unlocked my bootloader and am trying to get TWRP on my phone but the app seems to be broken and the website won’t load for me to get the image. On my desktop I managed to download the installer for TWRP (can’t get the img though because the website is being garbage for me right now) but don’t know how to go from there to installing it on my phone. Any help would be greatly appreciated.

I managed to get the img file and tried flashing it via the command line of my computer and got the error “FAILED (remote: partition [recovery] doesn’t exist)”, any idea what to do?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I don’t have a Google Pixel, but https://doc.e.foundation/devices/sailfish/install says

"on some devices the below command may be required
fastboot boot <recovery_filename>.img"

https://twrp.me/google/googlepixel.html says this, too.

And better don’t fastboot flash boot <recovery_filename>.img (also according to https://twrp.me/google/googlepixel.html)

This all sounds to me like the Google Pixel is an A/B device, these don’t have a recovery partition, so your error message would be correct.

1 Like

Thank you. I that managed to lead me down the right path to fix it. Though I will say if anyone has a pixel and stumbles across this while trying to flash their phone, it was a huge pain and I think virtually every other step on the wiki threw an error at me.

If you could specify more error messages, perhaps the wiki could be made better.

My guess is that the install guides are based on a set of templates for a rough fit when a device gets supported initially, and with user feedback they can get more specific and fitting over time, so specific error messages may help.

1 Like

Sure, I will post what I remember here.
First off, I tried using the TWRP app for Android to help and that app is not great, just use the command line. It crashed on me at least a dozen times and I never got it to work. I was also having major issues with the TWRP website not loading consistently. So maybe the servers were having a hard time or something? Hopefully it gets fixed for others.

Secondly, when I finally managed to get to TWRP I kept getting an error similar to this where it was failing to mount /vendor and /system and to my knowledge, no solution online solved this error. That means that every step inside of TWRP aside from sideloading the zip, didn’t work at all because those partitions didn’t mount. So the whole part in the documentation of installing /e/ from recovery didn’t work but luckily sideloading did so I was still able to flash it. I tried with 2 (maybe 3?) different versions of TWRP (3.5 and 3.4) and they both had the same issues.