Incoming phone calls are rejected

I just got /e/ running on a Samsung galaxy S7.
Outgoing phone calls are fine. But all incoming phone calls are rejected to voicemail. Unless a phone call is already being made.
I have looked at many settings, but I am stuck… It is not a network setting (I inquired *#61#).
Any ideas ? Should I fill a bug report ?

Have you check the “don’t disturb” option in the “state bar” ?

Thank you for your help.
I did check this button. It is off. I checked the ringing volume as well.

Do not have a Samsung phone but can you check in the Phone app settings if outgoing calls are barred
Dialer / phone app > more > Settings > call blocking and see if there is an option to block outgoing calls.
Alternate route could be Dialer app > Settings > Voice call > call barring > All outgoing calls > enabled/disabled

I have checked all these settings. Unfortunately there is no simple reason why incoming calls are rejected. Today I tried forced 3G instead of LTE but it did not help either.
Thank you for your ideas.

One more thing: switching to a 2G network solves the issue. But this is not quite acceptable…

Had a similar issue with my phone when I was on LineageOS and later for some time on /e/ - was not able to accept incoming calls or end calls had to reboot to close calls. Finally had to change the Preferred network Type …Setting >> Network & internet >> Mobile Network >> Advanced >> Preferred network type …had to set it to LTE for the issue to resolve.

Thank you for your answer.
On my Samsung S7 setting network to LTE is not enough. Data transfer and outgoing calls are fine. Incoming calls are not working.
Should I report a bug ?

Yes please put in a bug with logs created after you tried to access an incoming call.

Ok. Can you remind me how to retrieve the logs ?

There is a link on the logs in the above post. You will find the log created in the folder you are working in

OK, thank you. !