Installed on Pixel XL (marlin)

I just wanted to report that I was able to successfully install /e/ on a Pixel XL (marlin) that had been updated to Android Q prior to installation.

I used:

I followed the instructions on the installation page. Everything went without a hitch.

Just wanted to to share my success in case anyone is researching for a future installation.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


Glad to here you didn’t get into any trouble, welcome in the community :wink:

Thanks for posting this, i came here looking to ask if it would work and saw this.
I went ahead with the install/flashing and was successful using

Awesome! Glad to hear it. Congrats.

Warning : Do not attempt to downgrade your smartphone in case you are on Android Q / LOS 17.0 …

This proves once again that the blanket warning message for OS change to /e/ OS 9-pie is not relevant.

Thanks @kiborg!

Also, a general plea for help.

I got a new Pixel XL marlin with factory Oreo on it and followed the /e/ instructions. I had issues (more on that later.)

My current problem is with the recovery.
I have to boot if from my PC using fastboot boot twrp-3.3.1-3-marlin.img.

When I install, twrp reports successful install on both slots. but it fails when I try to boot to recovery.
After starting twrp from an image file, I can install /e/ and /e/ works beautifully. But then booting into recovery brings up the LineageOS recovery. If I then install the twrp zip, then /e/ doesn’t start (forever bouncing ‘e’ and the phone gets hot.)

So it seems I can either have /e/, or twrp installed, but not both.
Without twrp, will the OTA updates work?

I’ve tried several versions of twrp.
I’ve not encrypted the phone.

Going around in circles on this all day while searching for new info. Any ideas are appreciated.

Regarding the install instructions ( I encountered 2 big deviations. The bootloader would not unlock as written, and the instructions for installing twrp are contrary to TeamWin’s instructions at (Perhaps attempting to flash twrp using fastboot caused my current problem?)

I just stumbled across a “solution.”

On the reboot page after installing twrp, it asks if you would like to install the Official TWRP app. If I deselect both options, then everything works fine - rebooting into twrp and booting into /e/.

It is repeatable.
-Don’t select installing twrp app, then /e/ runs fine.
-Select installing the twrp app, then /e/ fails - stuck at bouncing /e/ continuously writing large volume to log; but it does respond to adb commands (reboot.)

Also, installing twrp version never works - the phone just goes black when booting to recovery. I have to hold the power button for like 20 seconds to wake it up. I’ve tried several 3.3 versions and they seem fine, as long as I don’t let them install the twrp app.

Maybe I’m doing something wrong?

Anyway, all seems to be working well with twrp and e-0.10-p-2020080666687-dev-marlin.

1 Like

Thank you for sharing your solution.

I don’t think so.
Anyway, TWRP app isn’t needed and the 4.0.0 version of TWRP causes trouble for a lot of people.

Welcome in /e/ :slight_smile: