Instant upload and system/OS upgrade both failing

I’m using a Murena Nord, for 6 months. No problems before now, gone thru, I forget exactly, 2 or 3 previous system updates with no issues.

I just realized that my photo Instant Upload stopped working a few days ago. I am not using the default eDrive tool, but my own self-hosted Nextcloud server. I have no idea what–if anything–I might have done to break it. The Instant Upload folders are still set up and configured correctly, it seems … but it’s almost like the file path has changed on the phone OS, and the Nextcloud app can no longer find any photos at the path it’s configured to sync from.

I’ve now tried several times to either reconfigure the existing sync folders, or create a new one … but every folder I go to shows “no files” in the folder. Tentatively, there seems to be a disconnect between /storage/emulated/0/DCIM/ (where I think my photos are), and Internal storage/DCIM/ (where Nextcloud insists on looking?).

So, but that’s actually the smaller problem. This prompted me to double-check my system update status, and I see there’s a new system update, available since 5/11. I can’t install it. The update fails 3 seconds into the attempt. No error message details that I can find, just a little notification at the top, that says “/e/OS 0.23 - May 11, 2022 Install error Suspend”.

The system tells me that I am currently running /e/OS 0.23-2022041175185, and that I am updating to /e/OS 0.23 May 11, 2022 (no detailed version number visible).

I have tried rebooting, and also deleting and re-downloading the update file. No joy.


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Exact same issue here. I also have a OnePlus Nord and get the same error on the new May update.

I can’t confirm the autosync problem because i haven’t configured my nextcloud yet.

You could install the update manually. After downloading the update, export it to a directory of your choice. Afterwards, turn off the smartphone. Now press the keys up + power until a menu appears on your phone. Choose an option like “Apply update” and select the previously exported update file. Now the update should work. When the update is installed, select an option like “Reboot into /e/OS” or something like that, if it doesn’t happen automatically. Now your smartphone should boot into /e/OS with the update installed.

I have the same issue with nextcloud.
I described the issue, in french, here:

No solution for now.

1 Like

Thanks. For now, this remains “Plan B”. Since the standard/default system upgrade is failing, I’m leery of trying it manually, in case there is something wrong with the upgrade itself.

ETA: Manual syncing to/from my Nextcloud still works fine – for now, I’m just doing a daily manual push of new photos/files to Nextcloud, which then get auto-synced to my other machines and local backup.

I have read that Nextcloud can be quite sensitive about versions !

It might be worth checking if the /e/ version of Nextcloud and your self-hosted Nextcloud server and your Nextcloud app are in the same version – just a guess.

+1 for install failure with May 11 update on OnePlus Nord. Manual install also not attempted due to possibility of something wrong with the update.

1 Like

With 3 reports of an upgrade failure, @rainbird @Sim0n @Vaughan it would probably be worthwhile to consider a downgrade to a previous working version.

There have actually been many re-releases of 0.23. On for this device, on stable I see three here /e/ image ROM download

The best way to get your version number in a format matching the /e/ image filenames is:

Settings > About phone > Android version > /e/ version > Long press on version number (should, I understand,) Copy to clipboard.

Please check to find if you have a version on your devices not exactly matching a currently published version. Also interesting to see if you all failed on the same version number.

Three reports really does justify Report an issue.

1 Like

I have “0.23-q-20220401175185-stable-avicii” installed witch was the newest stabel version when i initially installed my phone. It is also listed in the ROM download.

I also have 0.23-q-20220401175185-stable-avicii

You are probably aware [1] that downgrade of /e/ version is relatively safe, I have done it a number of times with testing versions without any losses. When on stable, be sure to stay on stable.

(One thing to be aware of, I guess, is if the failed upgrade caused “harm”, the downgrade might not carry out a “repair”. I think this is an outside chance – just saying so that I avoid appearing to say this course is absolutely without downsides !)

I have no direct experience of /e/ recovery, so will link this

[HOWTO] use e-Recovery to wipe & format data before sideloading/install eOS.

There is no good reason to delete or wipe data at this stage. A wipe of /system will be safe because you intend to fully replace it with your downgrade image. A wipe of Cache + Dalvic/ART Cache is always good practice (only transient data is deleted) and is useful when you are trying to correct an error.

As always, backup important things before attempting repairs !

[1] Forgive entry level information where it is not required !

You can check this in the updater by pressing the three dot menu of the offered download and copy the url somewhere to read it.It helps to know it’s a correct version.

Ditto … 0.23-q-20220401175185-stable-avicii

My system updater is trying-and-failing to install 0.23-q-20220511185000-stable-avicii

So, it has been over 3 years since I actively experimented with flashing custom ROMs, or anything else involving TWRP (beyond looking at it while /e/OS auto-updates itself) … and at this point, I’m pretty nervous about a manual downgrade on my primary phone.

Tentatively … is the idea to manually downgrade to the previous 0.23 version, make sure that works, and then run the /e/OS auto-upgrade directly to the latest, skipping over the version I have now?

Eg: I am currently running 0.23-20220401 and I want to upgrade to 0.23-20220511 … so I would manually downgrade (via TWRP) to the previous version (looks like 0.23-20220228), make sure that works, and then let /e/OS auto-upgrade itself directly to the 0511 version, skipping over my current 0401 version.

Because this is an official Murena device I would try to get some help from Murena first before manually installing/updating anything; especially as others have the same problem.

@Manoj can you perhaps help here?

So, without the device, my general advice may not be so useful. I had mentioned downgrade because if you all had working versions and the upgrade seemed to cause the problem, in the first instance I would think of downgrading. But there does seem a problem to fix with the build. There was post on Telegram also.

As @chrisrg mentions, as customers you can expect to get more accurate advice from

You are suffering 0.23-q-20220401175185-stable-avicii when
e-0.23-q-20220511185000-stable-avicii exists, but uninstallable (I think).

The problem with this update was reported as an issue yesterday (not by me):

I guess we just have to wait.

1 Like

Pl can you check if the issue you are facing is the same as reported here
If yes pl can you add your comments to the issue
Will pass on to the dev team to update the issue details in Gitlab.

Done. Definitely sounds like the same issue. I also referenced this forum thread and mentioned that 3 of us have all reported the same issue here in the form.

Thanks, @Manoj