Is there a newer rom for condor then e-0.7-n-2019112732147-dev-condor

No problem. Thanks for trying. I have a way forward to explore (changing content of file src/NOUGAT/vendor/cm/config/ to leave out unneeded / unwanted apps

Most apps are in /packages/apps and in prebuilds/prebuildapks

You can check my script what is unneeded

That link gives me a ‘File not found’ message

One more

Better i hope

I have checkt both links. Both are working

That worked. Thanks very much

I’ve tried removing apps /srv/e/src/NOUGAT/vendor/cm/config/ and I’ve tried using your script, but I still can’t get a condor ROM to build so I’m stopping. I’ll keep an eye on issue #1172 and I hope to be able to build a condor ROM when it is fixed. Thanks again for your help

Have you checked if the apps really deleted? Because docker makes everytime a repo sync.
And have you also removed unneeded prebuild apks?

Yes. I copy my modified to /srv/e/src/NOUGAT/vendor/cm/config/ after the repo sync and before the build starts. Confirmed in the log file that the removed apps are not built. And the image size has reduced from 1067MB in the unmodified version to around 861MB.

No. I’m afraid I don’t really have the time or interest to experiment any further. I can live with the current ROM on my condor device until issue 1172 is fixed and it is possible to build a condor ROM without manual intervention.
I also plan to set up a build environment at home and I will spend time setting that up rather than building more ROMs o cloud servers.
Thanks again for your help

That makes no differences I have learned. You MUST remove the apk. You can check that in /out/product/condor/system. You will see, all apps which you have removed in are sill there :frowning:

The whole build process of android is so sad against every programming rules. I’m getting always angry when I have to debug an learn that the build is doing things which he should do. It’s using folders which aren’t for the actual build and and and.

I have downloaded nougat sources, because I would try. But i can’t find any vendor blobs in your roomservice.xml
And on Github, there a a lot of different condor versions available

Do you know, which one is yours or from where the vendor blobs are coming ?

The logfile says
>> [Thu Jun 4 04:30:44 UTC 2020] Use branch cm-14.1 on
so I presume the blobs are from

yes, thx, have seen and a new repo sync is just running

If you want, you can try this small eOS version I have just build for you.

It will be available in around half an hour (my upload to ecloud is very slow)

Thanks. I’ll download it and give it a try tomorrow.
Which apps and packages did you leave out?

It has only Bliss, Mail, AccountManager, MicroG and Tasks

I tried the ROM and it booted up fine - thank you!

Then I restored (via TWRP) a recent backup of data partition to get back my installed apps and data.

When I rebooted, I got an error message ‘System UI keeps stopping’. I muted the error. The phone was functioning but there was no Launcher / UI - the screen was blank. The phone reacted as expected to power button.

I thought it might be related to OpenLauncher - my default launcher. So I flashed your ROM again and installed OpenLauncher. Restored data partition again, but same system ui error message.

For now I’ve gone back to my backed up system as I need a working phone today. When I get time, I will try again with your ROM, installing missing ‘system’ apps (Message, Aurora store, Music, Apps, Nextcloud) before restoring my data. I don’t want to manually install all my apps and data. I may give that a try this evening, particularly of it rains :slight_smile:

On my restored system, Account Manager keeps stopping. I’ll try re-installing

that’s normal. in your /data backup are information for apps which aren’t available in the small eOS version. If you need to have the data restored, you should stay on your old version til a full version will be available. Sorry

I think that will also not work, because when you are installing the apps, they are located in data. when the are coming with the OS they are located in /system.

Good point. I’ll wait until I have time for a manual install of everything I need

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.