Issue with an app - try before buy

So I have a premium account and am very happy with it as well as the entirety of the murena ideals. I have also downloaded and installed /e/OS on my current device to make sure everything works well with most of my current apps. However, it seems that I cannot successfully install the Dunkin Donuts app (the version of the app that I can access my digital Dunkin card) and I obviously don’t want to lose the funds available to me through the app. Is there something I can do to remedy this? I am willing to push aside a few of my apps and tech that can not be deGoogled, but that is one thing I kind of hope to save. Please help.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

May you elaborate? Does it install or not? If it does is it crashing or…?
What is the package name, OS version and/or build.

On 1.10-r I installed the main Dunkin’ app twice. From App Lounge (anonymous) and Aurora Store (G acct).
Installed and ran fine. Did not test beyond that.
Package name: com.dunkinbrand.otgo I think.

App has a lot of trackers. If it installs but does not behave make sure Advanced Privacy isn’t blocking anything.


Thank you for your reply. Okay, so I am installing the Dunkin app with the package name “com.dunkinbrands.otgo”. It does install without an issue but when I start it, after several seconds of showing the Dunkin Donuts logo, it shows the TOS header with an error message on the top of the screen that states, “Unable to download app policies. Please check your connection and try again.” (I have attached a screenshot) Does this have something to do with Advance Privacy? And if so, how would I go making an exception for it?

Again, many thanks for your assistance with this!

Kind regards,

Ah yes, that error sounds like something is blocked, maybe.
I do not use Advanced Privacy for my tracker blocking but tried to reproduce.
After installing again I blocked all trackers using another tool.

No issues. Got the app policies, then some brand ad, then it seems to get stuck at a Dunkin logo. Hitting the back button fixed that and all was good.

Unblocked the trackers. Turned on Advanced Privacy’s tracker blocking. Cleared data and cache of app to start fresh. App still performed okay. AP shows blocking 8 of 8 trackers and 12 blocked leaks.

Advanced Privacy may be blocking additional trackers in your build or maybe…
Are you using the hide IP feature of AP? That could put your location somewhere the app doesn’t like(??). If it is on go to the ‘Manage my internet address’ section. There is a part there that says “My internet activity must appear from:”
Random country is default. Pick from the selection and choose the country you live in. Test Dunkin again. Fingers crossed.

Sorry I cannot reproduce. Will test on another /e/ device once it charges.

Settings → Advanced Privacy. Toggles at top show what features are enabled.
Settings → Advanced Privacy → Manage apps’ trackers. Scroll down to find apps.
Settings → Advanced Privacy → Manage my internet address. Hide IP using Tor.


Well just about all of the Advanced Privacy settings are defaulted at what it was when I installed e/OS. So yes, that included the location. However, I followed your instructions and voila… it worked perfectly. Many thanks. I set the location close to me (in the same state) but still far away that my real location is hidden. Many thanks once again for all of your help. Still learning how e/OS works and so far lovin’ it. Support is great too (wink)!


Kind regards,

1 Like

I don’t know about Dunkin’ Donuts specifically, but I’ve found for many brand apps the QR code/bar code is the only essential feature (for me) - I can scan it at the till to build up points, and to spend them. So I keep a folder of images of QR codes, bar codes and loyalty cards (with a link to open the folder on my home screen).

Given that what the rest of what most brand apps do seems to be tracking (as @marcdw notes) and you “like the entirety of the Murena ideals”, would this be a possibility for you?

1 Like

This topic was automatically closed after 89 days. New replies are no longer allowed.