Jellyfin wont get updated

Hello community,
my Fairphone 3 with the latest 0.17 /e/ installed on it has some troubles updating the app Jellyfin.

It should be updated to version2.3.0.beta1, as it is the version in the F-Droid store right now, but the update just finishes with “The app couldn´t be installed”.

All other apps are updating fine. I also tried to download the .apk (Releases · jellyfin/jellyfin-android · GitHub) and ran the insall manually. Unfortunately it ended up in the same result.

Can someone confirm that?
Any chances for me to get rid of that?

Any hints?


Sorry to bump this up, but i still have this issue that the Jellyfin app can´t be updated.

Can anyone have a look into this, or try itself?

Thank you!

Looks to me to be a signature mismatch issue.
From what I see, F-Droid does not offer a beta version but standard release versions. 2.3.0, 2.3.1, and 2.3.2.

The version you are currently running, where did you get it from and is it also a beta?

Also, F-Droid apps (via the F-Droid repo) have their own signature as the apps are built by the F-Droid team. You can’t mix and match builds from GitHub and F-Droid. [ One of those things a lot of folks don’t realize when they ask devs on GitHub why their latest version of app X isn’t available on F-Droid ]

Whatever version you have now you will have to uninstall it first. If Jellyfin has a settings backup feature, use it, or if rooted, use your favorite backup utility to save the data. Otherwise…

EDIT: Jellyfin 2.3.2 is also available via /e/ Apps store. Probably not important, mentioned just because. :relaxed: