Lost webdav contacts/calendar after update to 0.5

app-contacts
webdav
support
xiaomi

#1

Hi,

I have a Xiaomi Redmi Note 4 with /e/ since 0.1 version.
This morning I installed the /e/ 0.5 (with OTA) and reboot the phone.
What a lot of changes. :sunglasses:

I lost all my contacts and calendar.
I use a webdav server (baikal) installed at home.
Since this update, no more accounts in Account manager, and so no more in the sms apps (signal or the new one qksms) and in etar.
So I recreated successfully the webdav account in the Account manager.
In this maneger, the account seems ok, I can see the contacts and the Calendar, the lists are ok and checked.
But in signal or qksms, there is no account for webdav, so no contacts.
And in etar, at start it ask for sign in to a Google account…??? and after cancelling in the settings the account is seen, but totally empty.

Is there specific changes to do for webdav accounts ?

Thanks a lot.
Axel


#2

My contacts & calendar needed also to be reconfigured.
Does this help: [PLEASE READ OTA] Moving to 0.5, changes, need to re-enable eDrive ?
In Accounts app > menu > Settings: you can change standard account for new contacts. Maybe you need to switch that?

Good luck,
David


#3

Thanks for your answer.

I tested to clear cache and to recreate the account and it not solved that.
When I create my webdav account in “Account manager”, all is good.
But when I go to the contact app, I have no contacts and with the 3 dots menu -> manage account, it opens Accounts app where my webdav account is not present. I tried to recreate from here and if the account was made from settings -> account -> add account, it says the account already exist but it not appeared in the list.
And if I try to delete my account from settings -> account, come back to the contact app and create the account from here, it create it, but it is still not listed in the app.

And, in Signal, when I want to change the default account for new contacts, I have only one choice: PHONE.
And it’s not possible to import any contacts, it does not find anything from SIM (I have contacts on my SIM, I verified with an other phone) and it does not ask for a file location for .vcf import…

I start to think, I will have to remake a fresh install.


#4

A late reaction, but it might help. For contacts, 3 dots menu -> Settings, there you can change “standard account for new contacts”. I need to change that and then I got my contacts back.


#5

Hi,
sorry but it’s not solved.

I don’t have any possibility to change the “standard account for new contacts”, because only “PHONE” is selectionable.
When I use the “Account Manager”, it seems to create the account, it gets the address books list and the calendar list, but it does not synchronise. I made a tcpdump on my baikal server, I saw the refresh requests for the lists but it never received a sync request.

I found a workaround to have my contacts back : remove the account from “Account Manager”, install DAVx5, and create a webdav account in DAVx5.
With that I see, with tcpdump, the refresh lists requests and the sync requests and so my contacts are back in “Contacts”, “Signal”, “QKSMS”, “Calendar”.

I created an issue : https://gitlab.e.foundation/e/wiki/en/issues/45