Magic earth frequently freezes up (FP3)

Magic earth used to run just fine on my Fairphone 3. Since I’ve updated from /e/ OS 1.3 to 1.5 it’s become very unstable, freezing up as soon as I try to start navigation / display navigation options.
Do others observe the same problem?

I’m generally unhappy with Magic Earth. I wonder if the /e/ developpers are really using /e/ themselves. For me, a good map application is the one thing that /e/ is missing today.

I just tried once since 1.5.1-s on my Fairphone 4.

Indeed, I started a 5 km route because I was lost in the countryside.
The screen immediately froze on the starting point, although the voice guidance continued normally.

I closed the application and have not tried it since.

Maybe check is this issue is opened on Gitlab…

I’m very happy with it. Seems currently like the best bet because there are no open source navigation apps with traffic information around.

Ok, maybe the navigator part is ok. That’s for the car drivers among us. I barely use the navigator.

couldn’t find an issue, so I started one:

to everyone: feel free to add your experiences there!

1 Like