Magic Earth incorrect version?

On opening Magic Earth I get a warning message saying that may current version is not compatible with the new map version and asking me to upgrade. But no new version is available in the official store!

my current version is:

I did not use the app for a while still this error is new.
What’s going on?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


Same thing happened to me on a Samsung S7.

Hi, same thing on my S9+. I upgraded it via Aurora (or F-Droid, I don’t remember) and its OK.

It seams that the issue is solved on the new (last?) version of the whole system:

and that the single app is not stand alone, i.e. cannot be upgraded but with the whole system.
So, I guess that in my case with a unofficial build there is no way to solve the problem.

Same here with version I updated to and now the update of maps is working again.

I updated through Aurora, but I found it searching for “magicearth”. Searching for “magic” or “earth” didn’t show “Magic Earth”, weird…

Other people reported the same experience (on Telegram channel), so I can try too.
Still I have two big questions:

a) apart from the security point of view, is it safe to update from that channel? Are the ‘internal store’ versions different from Aurora (PlayStore) versions.

b) is the system update (re-build from update source) actually a solution? does it depend on the particular phone?

just confused…

1 Like

I upgraded through Aurora, too. And everithing seams to work fine…
Doubts stilo remain…

1 Like

My current version is
The app is ‘integrated’ in /e/ and therefore I can not update.
There is no update for my nexus 5.
Can anyone tell me how to upgrade?
If I open an appstore, I can only see that Magic Earth is installed and can be opened, no upgrade.


Not sure it will work, but I’d install Aurora to see if by any chance they carry a newer version of Magic Earth.

Maybe a stupid question: how can I uninstall the app?
I tried using the remove/uninstall on the homescreen: not possible to uninstall.
I also tried to uninstall through the settings: not possible to uninstall.

You are certainly right and I have misinforme you…
I actually don’t have a fonctionnal device to test.
But try to update the app if you can’t uninstall it.
As the apk has not being modified by the /e/team, it still have the original signature, you would be able to update it from the Magic Earth web site or Aurora store

Maybe, maybe not.
I tried to use APKpure or Fdroid (not sure which one I tried) but the effect was the same as the /e/ App store: I can open the app, but there is no upgrade available.
Therefore I think that if I install Aurora it will have the same effect.
/e/ App store, APKpure, Fdroid, Aurora… I would like just 1 App store for all apps…

1 Like

In my experience (see previous answer) Aurora update worked perfectly. No need to uninstall anything, just upgrade (look at the version number, it was (is?) more updated.

Yep, I’d like to have only one store, too. But in case like this (system app with no system upgrade, since I have an unofficial build). And also F-droid has many good apps not included (yet?) in the ‘official’ store.

Aurora Store simply propose
to replace my old version from 2020.01.18
by the actual version from 2020.09.25

According to my personal experience and to other’s, that upgrade should do the trick!

Today I received an update for my Nexus 5.
After updating Magic Earth disappeared and is no longer part of the new build.
I downloaded Magic Earth form the /e/ appstore and downloaded new maps.
Everything seems to be working fine now.

/e/Maps is Out of the recents nougat builds because with it « the image of the /e/system is bigger than the space allowable for a /system partition by the .pit of the stock-firmware of this device »