Microphone not working Xiaomi Mi 6X /e/os 22

My microphone isn’t working since some days. At first it only didn’t work for phone but was working on signal or telegram. Now it’s not working anymore in any apps, even microphone recorder. I thought that the problem comes from some apps that I add that recorded calls (call control, ACR) and I uninstall then and at first it worked but now it seems that it doesn’t work anymore. Yesterday the microphone worked in the evening but today it’s not working no more.

Do I have to uninstall /e/os and reinstall ?
I followed all the tutorial to install the version 0.22 one week ago. The issue appears some days ago.

Thank you for your help.

Update : the microphone is working on the camera app but the hearing is very low.

2nd update : It’s working sometime. I add a call on telegram recently that worked. Then I try to call back and have taken a call from telegram and the mic didn’t work again.

New update : I have factory reset my phone and I still have the problem. The microphone is working intermittently.

Now I’m trying to put back the stock ROM on the Mi 6X but I get the “Anti-rollback check failed” and so I can’t boot TWRP and can’t install stock ROM from MiFlash. Please can someone help me I’m stuck !

… hmmm … As I understand it … you decided to go back to a Xiaomi Stock ROM?

In this case we study the error with MiFlash? “Anti-rollback check failed” - Were you trying to install the correct, latest full ROM for your device?

Am I right to assume the Android version you were on with /e/ is Android 10?

Before /e/, did your device start from the Latest ROM and was it Android 10, q ?

… and to double check, this is the device Install /e/ on a Xiaomi Mi 6X - “wayne”

Thank you for your answer aibd.

I could solve the “anti-rollback” by unlocking the phone from Xiaomi Unlock tool (I had unlock it at once but it gets locked again (maybe) after installation of /e/OS.

TWRP was stucked on the logo screen but I think it was a version problem because I finally could launch it from this version recovery-TWRP-3.3.0-0425-XIAOMI6X-CN-wzsx150.img available on this link : https://mifirm.net/downloadtwrp/36

I could flash stock MIUI ROM for Xiaomi Mi 6X (same website as above) but I get the same problem with the microphone. I tried all last version from 9.x.x to 12.x.x. I couldn’t find Android 10 for Xiaomi Mi 6X from my research and I thought that MIUI 12 was the last version of the stock ROM for the phone (to follow the instruction).

There’s not any indication on where to find stock ROM on the tutorial. If you know where I can find it I would be grateful. There’s more than one week I’m trying to make the phone works.

Now I find a version of Android One and I will try to install /e/ from there.

Caution: Before following these instructions please ensure that the device is on the latest Android Stock firmware same as the version of the /e/OS you are planning to install. This can be done by checking for OTA updates available in the Updater. If available run them before installing /e/OS.

You seem to have tried to meet that advice.

I had a quick look in here: Mi 6X (wayne) Firmware Downloads | Xiaomi Firmware Updater and I did not see Android 10 … so with Q, Android 9, it seems you are on the latest manufacturer firmware. To be honest, I have no information on whether MIUI version is significant.

I asked about versions in case this was connected to your “stuck” position … and that seems resolved.

In testing the microphone, were you able to try to test the microphone in Xiaomi firmware? … or are you saying that the microphone issue existed with Xiaomi firmware?

Are you able to test the microphone in another app like sound recorder?

I tried the microphone on the stock firmware but gets the same results. The microphone is working on recorder or on videos recording but when I’m calling (also on telegram and signal) it’s not working anymore.

I have tried /e/ installation from Android one and I couldn’t make it work again. I have install lineage 18 at once and I could make the microphone work on call. Then I reinstalled /e/ and I couldn’t make it work again even after installing lineage 18 again from there !

I’m giving up. I will send back the mobile phone to the reseller. It seems that it’s a recurrent problem on Xiaomi. Last time that I bought this brand. I have an Mi A2 it was working very well until a replaced battery inflate. Now on this one the minus shock makes it restart. I’ll go on Samsung like a friend suggest me. Hope it’ll be good.

Thanks anyway for your help.