Miracast and BuildProp

Has anyone been successful in adding:


To BuildProp on a Pixel 3 xl?

When I add the line and reboot, e hangs at the bouncing dot.

I used the BuildProp app from the apps store and gave it SU. It seemed to work. Was I supposed to add to a certain section?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

didn’t try miracast yet, but just a general info: if you change buildprops, usually they check for running and present system services and their libraries. Just flipping the option it no panacea. Could explain the hang.

As soon as you see the bouncing dot you have adb logcat output - so you can read into what it is complaining about

Great info, as I am a total newby.
Thank you!

looks to be rather involved: you’d need to bring back a 12k line patch (GitHub - sbjbs/android-wfd-patch: Android Pie wifi-display patch) that applies to libstagefright + libmediaplayerservice - that was deleted from AOSP Pie, check it out: [Guide] How to Enable Miracast for Pixel | XDA Forums - either the patch still applies cleanly or you need to bargain. You’d need to build the libraries yourself…

xda has creative solutions. The e forum didn’t have successful reports “miracast” from a superficial search

The other option is to use Chromecast and only power it on when you need it, put in guest network, config privacy, etc…but, how bad is that (compared to using an alternate device with apple TV because this won’t work). And, are there risks for having google home on the phone?

risks? no, no risk.

… looking into that patch repo again where it links to - seems to me as Lineage 18.1 and up has miracast code again in their android_frameworks_av - https://review.lineageos.org/q/legacy-wfd

On what device and /e/ version are you? if it’s /e/-R I’d be interested in seeing adb logcat output

Answers in recent threads explain a bit. LineageOS: search results - miracast

I am using R on a pixel 3. I can test on 3 xl, too. I don’t know how to get that log file. I can break it, again, and send to you.

Sending a quick update…I gave up on Miracast with the Pixel…don’t waste your time.

Casting on a Moto G7 Plus worked OK, but it was flakey. Sometimes it would connect as audio only, other times it would have video and no sound. In this case, we would have to do a dance with bluetooth and the soundbar. Depending on which was connected first, one might kick the other off.

Needless to say, it was NOT an Apple TV kind of experience…until I tried a OnePlus 7T (the last 4G only OP series). Now, casting works very similar to Apple TV, with an extra step of accepting the connection on the TV. Sound works. Video works. It’s a beautiful thing.

I understand why the Pixel did not work (they are forcing you to use Chromecast). As for the Moto being flakey vs the OnePlus working great, I am leaning towards hardware. The OP7T has the SnapDragon 855+, which I think the “+” was focused on video for games.